This question is an exact duplicate of:

When I try to finish creation of a new VM from an iso, I get this error:

'internal error: process exited while connecting to monitor: 2018-04-11T00:42:51.993762Z qemu-system-x86_64: can't apply global IvyBridge-x86_64-cpu.spec-ctrl=on: Property '.spec-ctrl' not found'

Traceback (most recent call last): File "/usr/share/virt-manager/virtManager/asyncjob.py", line 89, in cb_wrapper callback(asyncjob, *args, **kwargs) File "/usr/share/virt-manager/virtManager/create.py", line 2545, in _do_async_install guest.start_install(meter=meter) File "/usr/share/virt-manager/virtinst/guest.py", line 498, in start_install doboot, transient) File "/usr/share/virt-manager/virtinst/guest.py", line 434, in _create_guest domain = self.conn.createXML(install_xml or final_xml, 0) File "/usr/lib/python2.7/dist-packages/libvirt.py", line 3659, in createXML if ret is None:raise libvirtError('virDomainCreateXML() failed', conn=self) libvirtError: internal error: process exited while connecting to monitor: 2018-04-11T00:42:51.993762Z qemu-system-x86_64: can't apply global IvyBridge-x86_64-cpu.spec-ctrl=on: Property '.spec-ctrl' not found

what can I do for make it work?

marked as duplicate by Christopher, G-Man, slm Apr 12 '18 at 18:24

This question was marked as an exact duplicate of an existing question.

  • 4
    It is pretty far from basically debian – llua Apr 11 '18 at 1:06
  • I mean, is based on Debian, and basically it is Debian, it uses the Debian installer too, but is rolling release model and with tools for hacking... So, any solution? – Jamil Gomez Apr 11 '18 at 1:14
  • 2
    I mean it is basically pretty far from debian – llua Apr 11 '18 at 2:59
  • Like far far away from Debian. Things are not always as they seem. – Kiwy Apr 11 '18 at 7:33
  • 1
    This is inside-out. Install Kali as a VM rather than trying to make it a Host. – roaima Apr 11 '18 at 22:42

Issue at Hand

According to the error you have posted this is hardly a problem limited to Kali Linux. It appears certain patches for spectre/meltdown have created an issue with the kernel and virtual machines.

I have found several links pertaining to this exact issue, all on different operating systems. Here is a link to a bug report for Red Hat. This link is to a forum post describing a solution for Arch Linux. Here is another forum post for a possible solution to the same error but for Manjaro. Someone using ParrotSec also reports the issue. Lastly I am including a link to the QEMU Wiki on CPU features as it also appears related. I suggest you read through each link first but from that quick search I was able to find some possible solutions to your problem.

1. Use the "copy host CPU configuration"

If you are launching a VM via the graphical interface of virt-manager try setting the "copy host CPU configuration" option under the CPU sub-menu of your Virtual Machine configuration menu. According to the provided links, this appears to be the best solution to the error you are encountering.

2. Missing permissions of Users and Groups

Make sure that your user launching KVM virt-manager is a member of the kvm and libvirt groups and try again.

3. Out of Date Versions

According to Jiri Denemark, the issue could lie with there being a problem with the kernel not supporting the newer CPU features.

This would suggest libvirt detected the new feature in the host CPU via CPUID, but the kernel is not new enough to recognize it. Moreover, qemu-kvm-rhev is pretty old and doesn't support the new feature either:

  • Fri Mar 24 2017 Miroslav Rezanina - rhev-2.6.0-28.el7_3.9

I think virt-install by default takes the CPU model from libvirt's capabilities XML, which is Broadwell-IBRS. Since qemu-kvm-rhev does not support the new CPU model, libvirt uses Broadwell,+spec-ctrl,+rtm,+hle instead.

In other words, this was just a temporary issue with the compose when libvirt is updated while others are not updated yet. The problem can be fixed by detecting CPU capabilities via QEMU and teaching virt-install to use the CPU from domain capabilities. Libvirt does so with QEMU-2.10.

Try making sure you have the latest version of the Kernel, your kernel headers, libvirt, virt-manager, and QEMU. Reboot after this and try again.


I believe option 1 to be your best bet. If not make sure you have everything correctly installed and up to date. The error message you are getting is very descriptive of the problem you have. Verify that the processor feature set it says it is using matches your hardware. Google is your friend. As always, if there are any misconceptions or issues with my answer please comment, I appreciate corrections to my mistakes. Best of Luck!

  • 1
    Thank you so much for your answer, kemotep, very informative and helpful! Well, I suposed that this problem was related to some newer implementation or patch in the kernel, I see that this issue is present only in Kernel 4.14+, I searched sollutions before, someone resolved using "copy host CPU configuration", I tried too but nothing happens... I will see all the information you posted. Again, thanks! – Jamil Gomez Apr 12 '18 at 12:58
  • @JamilGomez No problem. Another consideration is that Kali Linux may be missing the fixes or even be fully capable of utilizing some features of virt-manager. In my experience Kali Linux works best when you only use software designed for Kali. Running virtualization solutions or hypervisors is not what it was built for. Again verify that you have the latest versions of libvirt, etc and not just the newest version available to Kali. You may have to start from scratch and install those packages from source. If your issue persists please file a bug report with the respective developers. – kemotep Apr 12 '18 at 13:07
  • 1
    thank you again, I will be patient, now I can run VirtualBox without any problems in Kali, but I will see in future versions if this problem persist or not, if yes I will make a bug report to the developers. – Jamil Gomez Apr 13 '18 at 16:10
  • "Copy host CPU configuration" got me past this issue, thanks. – Dzamo Norton Apr 17 '18 at 7:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.