I install windows and resize its partition. I then try to install debian in the remaining space. As it's installing the base system, it consistently gives me the following error message: "No Installable kernel was found in the defined APT source". This has never happened when I just use the entire disk.

I tried ignoring the message and continuing. When it finally started grub 1.99 (this was debian testing), it gave me a prompt asking me to enter a command instead of the normal "select the operating system" screen. I messed around and got another message which said something along the lines of "no kernel is installed."

Why is this happening? What difference does it make that I'm now trying to install onto a smaller partition?

The same thing happens with debian stable.

closed as not a real question by Gilles, Renan, daisy, Mat, Tim Kennedy Sep 26 '12 at 19:22

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.


I solved my own problem. I used this single usb to boot different versions of linux in the past and some of the previous configuration files may have screwed something up. After I deleted everything from the usb and made it bootable again, everything worked just fine.

  • so it's better to use one but fast flash ..for single install – Xsi Nov 23 '12 at 17:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.