1

I recently installed Debian 9 on a Macbook Pro (8,2), so I used the version with non-free firmware, as I read it was needed to make everything work properly on a Mac.

The problem is that whenever I reboot the computer it gets stuck on boot, showing only:

dev/sda1: clean, 552599/6111232 files, 7119295/24414464 blocks

After a long time of research I found out a way to fix this and I was able to boot again.

  • Boot the computer and press e when GRUB screen appears
  • Add nomodeset between ro and quiet on the config file
  • Press F10 to boot (fn + F10)

Now I have to do this every time I reboot ...

For what I read the problem has something to do with the graphics card firmware, but I couldn't find how to fix it.

Any idea what it could be happening and how to fix it ?? so I don't have to do the little hack every time.

3

One can cause the parameters to be used on each boot. As the user, root, edit the file, /etc/default/grub, and modify the line, GRUB_CMDLINE_LINUX_DEFAULT, to specify all of the desired parameters. Then update GRUB with the command, update-grub.

According to Ubuntu Forums,

nomodeset

The newest kernels have moved the video mode setting into the kernel. So all the programming of the hardware specific clock rates and registers on the video card happen in the kernel rather than in the X driver when the X server starts.. This makes it possible to have high resolution nice looking splash (boot) screens and flicker free transitions from boot splash to login screen. Unfortunately, on some cards this doesnt work properly and you end up with a black screen. Adding the nomodeset parameter instructs the kernel to not load video drivers and use BIOS modes instead until X is loaded.

Note that this option is sometimes needed for nVidia cards when using the default "nouveau" drivers. Installing proprietary nvidia drivers usually makes this option no longer necessary, so it may not be needed to make this option permanent, just for one boot until you installed the nvidia drivers.

The other question that you posted indicates that you are using the laptop as a home server and that the lid stays shut and monitor turned off. This seems to imply that you do not intend to use the video much anyway. And there's no "problem" with nomodeset, per se. If you want to get a proprietary driver working instead, please post the details of your video hardware.

# Refresh the PCI ID list.
sudo update-pciids

# Look for information about the video card.
lspci | grep -E "VGA|3D"

The output from the last command might be as follows.

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen [...]

Use the PCI ID to get more information.

sudo lspci -v -s 00:02.0

Add the result to the question.

  • that's awesome! thanks. I was looking more to fix the underlaying problem (I do not now the implications of nomodeset), but I guess this will do for now – Pablo Lorenzo Apr 10 '18 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.