Notice: This is not about dual booting, I can setup GRUB to dual boot with Windows 7 later. I just need to be able to get into Arch Linux.

Last night I installed Arch onto my computer via netinstall and it all went smoothly, but when I went to reboot... it loaded up the GRUB menu and it listed Arch Linux, but when I select it, I get "Error 15: File not found."

I've been googling and trying various way to fix this problem but I always get the same error.

Some info about my partitions:

  • /dev/sda:

    1. Windows 7 System Reserved
    2. Windows 7
  • /dev/sdb:

    1. Data (Movies, Music, etc..)
  • /dev/sdc:

    1. Separate Boot Partition
    2. Swap
    3. Separate Home Partition
    4. Root
  • /dev/sdd:

    1. Pendrive

The followings are outputs of various programs and contents of various files.

ubuntu@ubuntu:~$ sudo blkid
/dev/loop0: TYPE="squashfs" 
/dev/sdb1: LABEL="Stuff" UUID="72D6355E32F06BD5" TYPE="ntfs" 
/dev/sda1: LABEL="System Reserved" UUID="A8F8AC7FF8AC4CFE" TYPE="ntfs" 
/dev/sda2: UUID="2A20B02620AFF6CB" TYPE="ntfs" 
/dev/sdc1: UUID="2a23abcf-b29f-4119-b406-0b1817e5c8e1" TYPE="ext2" 
/dev/sdc2: UUID="f3d9ce0d-5953-4f4e-885a-4cd2ebf6b6e9" TYPE="swap" 
/dev/sdc3: UUID="2a53bdc8-7a9a-4dd2-9aef-5b7b4c3e74a4" TYPE="ext4" 
/dev/sdc4: UUID="7b4faa93-98db-49e3-ad41-92e9dc60deda" TYPE="ext4" 
/dev/sdd1: LABEL="PENDRIVE" UUID="0290-E580" TYPE="vfat" 


timeout   5
default   0
color     light-blue/black light-cyan/blue

#===--- Arch Linux
title  Arch Linux
root   (hd2,0)
kernel /vmlinuz26 root=/dev/disk/by-uuid/2a53bdc8-7a9a-4dd2-9aef-5b7b4c3e74a4 ro vga=775
initrd /kernel26.img

#===--- Arch Linux Fallback
title  Arch Linux Fallback
root   (hd2,0)
kernel /vmlinuz26 root=/dev/disk/by-uuid/2a53bdc8-7a9a-4dd2-9aef-5b7b4c3e74a4 ro vga=775
initrd /kernel26-fallback.img

#===--- Windows 7
title         Windows 7
rootnoverify  (hd0,0)
chainloader   +1


# /etc/fstab: static file system information
# <file system>        <dir>         <type>    <options>          <dump> <pass>
devpts                 /dev/pts      devpts    defaults            0      0
shm                    /dev/shm      tmpfs     nodev,nosuid        0      0
/dev/sdc1              /boot         ext2      defaults            0      1
/dev/sdc2              /             ext4      defaults            0      1
/dev/sdc3              /home         ext4      defaults            0      1
/dev/sdc4              swap          swap      defaults            0      1

1 Answer 1


The main thing that seems wrong here is that in the line

kernel /vmlinuz26 root=/dev/disk/by-uuid/2a53bdc8-7a9a-4dd2-9aef-5b7b4c3e74a4 ro vga=775

You are using the uuid for /dev/sdc3 which is your /home partition, you should be using the uuid for /dev/sdc2 which is your / partition.

Also... the output from sudo blkid does not match what is shown in fstab. In blkid the swap partition is /dev/sdc2, but in fstab the swap partition is /dev/sdc4...

You need to figure out these descrepencies.... then you can try to re-configure your grub.conf

Some pointers:

  • Have you tried other values of root, like root (hd2,1) ?

  • Instead of

    kernel /vmlinuz26 root=/dev/disk/by-uuid/2a53bdc8-7a9a-4dd2-9aef-5b7b4c3e74a4 ro vga=775`

    you could try things like

    kernel /vmlinuz26 root=/dev/sdc2 ro vga=775

  • Make sure that /boot/kernel26.img exists.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.