1

I use i3 as my primary user interface. To start applications I use Rofi which I execute as:

rofi -show drun -drun-icon-theme MacBuntu-Remix

where MacBuntu-Remix is a theme I have installed in ~/.icons. On Gentoo Linux this command causes icons to appear next to application names in Rofi, but under Debian this exact same command, with the exact same ~/.icons folder, produces a Rofi menu without these icons next to applications. Anyone know why? Did the Debian packagers decide not to compile rofi with this option, or?

To fix this I've tried switching from using Rofi in the Stretch repositories to using Rofi in the unstable repository, in the hope it was simply an older version of Rofi that was causing the problem, this didn't fix it, however. I have also tried switching icon themes to something I was certain was installed properly (although I was confident MacBuntu-Remix was it appeared fine under GNOME), Adwaita. The icons didn't appear then either. Here's a screenshot of Rofi running under Debian 9, started with the above MacBuntu-Remix theme command:

enter image description here

2

I wasn't seeing icons on Debian Sid either.

Have you tried the -show-icons option?

rofi -modi drun,run -show drun -font "DejaVu Sans 10" -show-icons
| improve this answer | |
0

I have managed to make it work using:

bindsym $mod+d exec rofi -show drun -show-icons -modi drun,run

in my i3 config file.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.