0

My /etc/default/keyboard reads

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="logitech_base"
XKBLAYOUT="gb"
XKBVARIANT=""
XKBOPTIONS="lv3:ralt_switch,compose:rctrl"

BACKSPACE="guess"

Yet, whatever I try, I cannot get any sign of the compose key working. I am on Debian stretch. What could be the reason?

  • If you try again directly with setxkbmap -option compose:rctrl does it work this time? You know that the use order is compose (then release it or not), then first key, then second key? – A.B Apr 7 '18 at 15:26
  • I changed it to compose:rwin and it still didn't work. I issued your command and now all of the sudden rwin gets recognized as Multi_Key by xev and works. I can't explain this. – Kappie001 Apr 7 '18 at 15:30
  • Me neither, except that the setting in the config file either doesn't work or is overriden. Anyway till you figure it out exacly, you have a workaround – A.B Apr 7 '18 at 16:02
  • Did you follow wiki.debian.org/Keyboard ? Perhaps changing the file is not enough, there are services to restart too? – A.B Apr 8 '18 at 10:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.