0

I am using Debian Stretch with Openbox window manager and I am trying to set the uniform look for GTK2, GTK3, QT4, QT5 widgets. Everything went smoothly except for GTK3 that partially ignores ~/.config/gtk-3.0/settings.ini file which looks like this (I used Lxappearance to modify it):

gtk-theme-name=Breeze
gtk-icon-theme-name=breeze
gtk-font-name=Roboto Medium 10
gtk-cursor-theme-name=breeze_cursors
gtk-cursor-theme-size=0
gtk-toolbar-style=GTK_TOOLBAR_BOTH_HORIZ
gtk-toolbar-icon-size=GTK_ICON_SIZE_SMALL_TOOLBAR
gtk-button-images=0
gtk-menu-images=1
gtk-enable-event-sounds=0
gtk-enable-input-feedback-sounds=0
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle=hintfull
gtk-xft-rgba=rgb

Option gtk-font-name=Roboto Medium 10 is completely ignored by all GTK3 applications which continue to use their default font Sans 10 while option gtk-font-name=Monospace 10 works. Other options like gtk-button-images=0 also work if I change them and restart GTK3 applications.

So what can I do to be able to use Roboto font in GTK3 applications inside my Openbox window manager?

Roboto font works for GTK2 applications in ~/.gtkrc-2.0. It looks like gtk-font-name="Roboto Medium 10" (mind the quotes which should be avoided in GTK3 configuration file). Roboto font also works for QT4 and QT5 applications and was applied using qt5ct...

So only GTK3 is making problems for Roboto fonts...

  • I tried converting Roboto font from ttf font to otf and it works now... I deleted it now. It was exclusively for testing purposes. Still reason why Roboto font doesn't work in ttf format remains unknown... – 71GA Apr 7 '18 at 16:24
  • Have you tried omitting the Medium part and leave just Roboto 10? – contemplator Apr 10 '18 at 20:51
  • Yes. Nothing changes. – 71GA Apr 12 '18 at 3:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.