0

Trying to build wmvare tools for 32 bit Centos 7. ./configure complains regarding XMLSECURITY library:

Cannot find XMLSECURITY library. Please configure without XMLSECURITY (using --without-xml-security-c), or install the XMLSECURITY libraries and devel package(s).

yum install xml-security-c not helped:

No package xml-security-c available

How to install xml-security?

I have option using --without-xml-security-c. What I will miss in that case?

I have took branch stable 10..0.x of vmtools since I expect it will not need newest libs and it will be easier to build.

UPD

I have installed xml-security :

yum install xmlsec1-devel

But still have same error. Why ./configure not sees this lib?

0

XMLSECURITY lib´s

# yum search xmlsec
.    
  xmlsec1
  xmlsec1-devel
  xmlsec1-gcrypt
  xmlsec1-gcrypt-devel
  xmlsec1-gnutls
  xmlsec1-gnutls-devel
  xmlsec1-nss
  xmlsec1-nss-devel
  xmlsec1-openssl
  xmlsec1-openssl-devel

On-line list http://mirror.centos.org/altarch/7.4.1708/os/i386/Packages/

Install example : # yum install xmlsec1-devel

  • This helped to install libs, but I still have the same error. Maybe ./configure is looking for any other directory ? – vico Apr 7 '18 at 9:50
  • Probably install xmlsec1-(gnutls)-devel , or whatever of {gcrypt, gnutls, nss, openssl} you want to use. – Knud Larsen Apr 7 '18 at 11:23
  • 1
    I checked open-vm-tools.spec from open-vm-tools-10.1.5-3.el7.src.rpm. You need to have xmlsec1-openssl-devel installed package. – Yurij Goncharuk Apr 7 '18 at 13:25
  • Have installed xmlsec1-openssl-devel, but still have same error. I have took branch stable 10..0.x of vmtools since I expect it will not need newest libs and it will be easier to build. Is that might be related to errors? – vico Apr 8 '18 at 7:26
  • Where I can find open-vm-tools.spec ? – vico Apr 8 '18 at 7:28

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.