0

I'm using Plasma 5 on Arch Linux, and I type with the Colemak keyboard layout. This layout should be able to enter an em-dash with AltGr+Shift+- (hyphen). At least, that's what it did on GNOME, and that's what it's supposed to do according to the KDE keyboard layout preview for this layout. But instead it's a dead key that puts a dot under the next letter. How can I fix it?

0

the Colemak layout is defined in the file /usr/share/X11/xkb/symbols/us

Looking at the most recent version available to me, AltGr+Shift+Hyphen (that would be the AE11 key right of the AE10 (the zero key) and left of the AE12 key (the equal key) it says emdash in the 4th column, so your assumptions are correct.

Perhaps you didn’t load the correct layout. What does setxkbmap -query say? (especially under layout and variant)?

| improve this answer | |
  • It says "layout: us" and "variant: colemak." Options are "terminate:ctrl_alt_bksp,caps:escape,grp:ctrls_toggle." I checked in /usr/share/X1/xkb/symbols/us under the Colemak section, and it looks fine. I don't know what could be going on. – Jonathan Apr 24 '18 at 21:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.