-3

I plan to move my VM to my VPS providerju, but I need Python module that is required by the mover app ( snf image creator). However it won't let me install curl. Then error says that curl and two additional libs are required as dependencies, but I have also broken packages. I tried to apply my apt-get knowledge (apt clean, autoremove,...), but it does not do the Job.
Updated image. Cannot / Don't know to copy text from VM ware player

Description od the error


I messed up my sources.list file while entering another repo

  • 2
    Welcome to U&L , Please post a text instead of an image , to translate from you locale language to Eng you can use (e,g) :LC_ALL=en_US your_command , Also the content of your /etc/apt/sources.list may be helpful , You can edit here. – GAD3R Apr 6 '18 at 7:53
  • Thanks for the advice. I took the photo before I went home from my dormitory. Sure i'll post this in english when get home. – S4NNY1 Apr 6 '18 at 8:41
  • Please, don't post images of text. – Kusalananda Apr 6 '18 at 10:16
  • Can you tell me how how to copy from VM vare workstation 14? I enabled all I could. – S4NNY1 Apr 7 '18 at 17:37
  • 1
    Thanks for the idea. It worked and packages are installing. I had proprably erased the whole sources.list file with echo "okeanost_repository_site" >> ..sources.list – S4NNY1 Apr 7 '18 at 17:53
0

Solution:

Example sources.list from Debian website Below is an example of a sources.list for Debian 9/Stretch.

deb http://deb.debian.org/debian stretch main
deb-src http://deb.debian.org/debian stretch main

deb http://deb.debian.org/debian stretch-updates main
deb-src http://deb.debian.org/debian stretch-updates main

deb http://security.debian.org/debian-security/ stretch/updates main
deb-src http://security.debian.org/debian-security/ stretch/updates main

If you also want the contrib and non-free components, add contrib non-free after main:

deb http://deb.debian.org/debian stretch main contrib non-free
deb-src http://deb.debian.org/debian stretch main contrib non-free

deb http://deb.debian.org/debian stretch-updates main contrib non-free
deb-src http://deb.debian.org/debian stretch-updates main contrib non-free

deb http://security.debian.org/debian-security/ stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security/ stretch/updates main contrib non-free

You can use a GNOME tool to edit your sources.list file. Access it through Menu → System → Administration → Software Sources.

gksu --desktop /usr/share/applications/software-properties.desktop /usr/bin/software-properties-gtk
  • I'll try the delete option. My package manager is apt and not apt-get. – S4NNY1 Apr 6 '18 at 8:42
  • The problem come from the sources.list, please see the update. – GAD3R Apr 7 '18 at 17:45
  • I added sourced.list in solution 0 – Dipankar Nalui Apr 7 '18 at 18:37
  • If this answer solves your problem, please accept the answer by clicking the answer button. Or, If you would have solved by yourself, please share the solution. – Dipankar Nalui Apr 7 '18 at 18:46
  • Just keep the first part of the answer. The 3 last solution will not help. – GAD3R Apr 8 '18 at 17:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.