-3

My PC has no HDD. I've installed Kali onto USB stick located in USB port 1 (/dev/sda). Kali installation media was in USB port 2 (/dev/sdb). Installation was successful.

When I put my USB stick with Kali installation in USB port 1 (/dev/sda) it boots just fine. But when I put it in USB port 2 or USB port 3, it fails to boot.

Also when I try to put this USB stick in another PC which has HDD installed (/dev/sda), it also fails to boot. But when I remove HDD drive from that particular PC and try to boot from my USB stick, it boots.

This is the error i'm getting:

[    4.217127] sd 6:0:0:0: [sdb] No Caching mode page found
[    4.217223] sd 6:0:0:0: [sdb] Assuming drive cache: write through
Gave up waiting for root file system device.  Common problems:
 - Boot args (cat /proc/cmdline)
   - Check rootdelay= (did the system wait long enough?)
 - Missing modules (cat /proc/modules; ls /dev)
ALERT!  /dev/sda1 does not exist.  Dropping to a shell!

BusyBox v1.27.2 (Debian 1:1.27.2-1) built-in-shell (ash)
Enter `help` for a list of built-in commands.

(initramfs)

How do I fix this so my USB stick with Kali will boot from any USB port?

I don't think my question is duplicate. The problem I have is that when my /dev/sda changes to /dev/sdb I can no longer boot /dev/sdb, but when it goes back to /dev/sda it boots fine. I've tried the following steps so far: 1. I've checked if /etc/fstab contains any references to /dev/sda. It doesn't. It uses UUID to mount root partition.

2

So... you installed Kali onto a flash drive from another flash drive? Here are my suggestions, because it is doubtful anyone will walk you through this:

  • Look into how to run Kali with persistence on a flash drive. There really is no need to be installing the OS on the flash drive, especially for what Kali is intended for. If not: (Again, this is the best solution)
    • Have you done any research on the obvious error output? It even lists common solutions. Attempt those and go from there. Do some research on the concepts of mounting/partitions/etc before jumping to reaching out for help. This is a general concept to live by for anything in the tech world.
    • Have you ever used Linux before? If not, I'd recommend not jumping straight into Kali. Don't be that person who jumps into Kali with no prior experience, and then flood forums with basic Linux questions ("How do I run commands? Why can't this script I copied execute?")

Takeaway: Jumping into Linux without researching problems and understanding core concepts is not the way to go. Enjoy learning so many new things and good luck!!

  • Thank you for your input. I've been using GNU/Linux for 8 years. I don't think it's an obvious error because my auto-generated /etc/fstab contains only references by UUID, and all solutions on the internet to "/dev/sda1 does not exist" mention only changing GRUB config to point to /dev/sdb instead of /dev/sda. They do not mention how to make USB universally bootable. – user9593274 Apr 11 '18 at 4:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.