0

My problem is systemd automount is mounting my ntfs filesystem as read only dispite me setting the options=rw

Following some online reference sites on setting up systemd with automount I created two files in attempt to have /dev/sdb4 mounted to /mnt/winblows

I've identified the PARTUUID of the partition, created the directory /mnt/winblows owned by wurst:wurst (that's my user account), created two files: /etc/systemd/system/mnt-winblows.automount and a coresponding mnt-winblows.mount With the following contents

mnt-winblows.automount:

[Unit]
Description=Automount Winblows

[Automount]
Where=/mnt/winblows

[Install]
WantedBy=multi-user.target

mnt-winblows.mount:

[Unit]
Description=Winblows

[Mount]
What=PARTUUID=38a287b1-46ca-4cbf-b887-956804a31b2d
Where=/mnt/winblows
Type=ntfs
Options=user,rw,uid=1000,gid=1001

[Install]
WantedBy=multi-user.target

I then performed the following commands:

sudo systemctl daemon-reload
sudo systemctl restart mnt-winblows.automount

However, when I touch /mnt/winblows/test I get touch: cannot touch '/mnt/winblows/test': Read-only file system

I am unsure how to correct this problem as according to man 8 mount the options rw should take care of that. Any guidance is appreciated.

1
  • Can you change the write permission of '/mnt/winblows/test' to writable? Apr 6, 2018 at 3:08

1 Answer 1

1

The native ntfs Linux kernel driver only provides read-only access to a NTFS partition.

In order to get read/write access, you should use ntfs-3g which is a FUSE (filesystem in userspace) driver that provides full read/write access. The details might be a bit specific to your Linux distribution.

Look for ntfs-3g package and take a look at man ntfs-3g.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .