1

Trying to install git to 32 bit Centos 7:

sudo yum install git

Got answer:

Requires: perl(Error)

How to fix that and install git? Why it is not trying to download perl if needed?

enter image description here

UPD:

Repositories list on my machine:

enter image description here

1
  • please as much as possible try not to put images but test in your question. it is very hard to work on images and search engine are bad at finding meaning in those. making your question almost invisible on the internet.
    – Kiwy
    Apr 5, 2018 at 8:44

2 Answers 2

0

Since you provide no information about which YUM repositories you are using (yum repolist), I can only guess that the package that provides perl(Error) does not exist in any of your configured repositories.

Looking at the CentOS 7 altarch repositories for i386, I was able to find the package so you should try configuring that repository and see if it works.

7
  • I have updated repo list in question body
    – vico
    Apr 5, 2018 at 7:32
  • You are missing base/7/i386 somehow, which would be the main repository with most of the packages, including the one you seem to need. Apr 5, 2018 at 7:40
  • How I can see repositories content in order to find git?
    – vico
    Apr 5, 2018 at 7:40
  • The repository I have been linking is browsable, but the git package is here: mirror.centos.org/altarch/7/os/i386/Packages/… Apr 5, 2018 at 7:41
  • 1
    that should do it, curious why someone would do that though Apr 5, 2018 at 7:53
0

perl(Error) is provided by perl-Error package. It is available in the x86_64 repository, but it is noarch architecture package, so it should be compatible. Check if your repo provides it as well and eventually enable/take it from the x86_64 repo:

ftp://mirror.switch.ch/pool/4/mirror/centos/7.4.1708/os/x86_64/Packages/perl-Error-0.17020-2.el7.noarch.rpm

The same for perl(Term::ReadKey) - package name perl-TermReadKey

2
  • How to check my repo provides perl-Error?
    – vico
    Apr 5, 2018 at 8:14
  • As mentioned in comments below GracefulRestart's answer, check your /etc/yum.repos.d and enable os repo (enabled=1). Then you should be able to get your packages. Eventually you may need to clean YUM cache (yum clean all). Apr 5, 2018 at 8:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .