-2

I installed Lubuntu 16.04 on my Lenovo 3000 N200 laptop, but the "Wifi Networks" is greyed out. In the process of installing OS Wifi hasn't been recognized. Then I decided to reinstall Lubuntu but now with Ethernet cable plugged in. Installation was longer because of simultaneous updates but never the less, Wifi is not working (Ethernet does).

I did my research on: https://ubuntuforums.org/showthread.php?t=2322093 and https://ubuntuforums.org/showthread.php?t=2214110 but not of that helped...

"sudo apt install b43-fwcutter firmware-b43-installer" was mentioned on other forums as well but it didn't resolve my problem.

Previos OS on this laptop was Lubuntu 15.10 and the Wifi was working properly.

PS. I also tried to add my home Wifi manually (entering SSID, Mode, Device and other settings)

1

Installing “firmware-b43-installer” offline

You need to install firmware-b43-installer.

If you do not have an alternative internet connection, do it this way.

If you installed bcmwl-kernel-source, then remove it.

sudo apt-get purge bcmwl-kernel-source
  1. Download these files

http://mirrors.kernel.org/ubuntu/pool/main/b/b43-fwcutter/b43-fwcutter_015-9_amd64.deb http://www.lwfinger.com/b43-firmware/broadcom-wl-5.100.138.tar.bz2

  1. Copy them to your Ubuntu Home folder.

  2. Run in terminal

    sudo dpkg -i b43-fwcutter_015-9_amd64.deb
    tar xfvj broadcom-wl-5.100.138.tar.bz2
    sudo b43-fwcutter -w /lib/firmware broadcom-wl-5.100.138/linux/wl_apsta.o
  1. Reboot or run:

    sudo modprobe b43

Note: For 32-bit systems download http://mirrors.kernel.org/ubuntu/pool/main/b/b43-fwcutter/b43-fwcutter_015-9_i386.deb instead of amd64 and update the file name in the dpkg command.

For Lubuntu 16.04 http://mirrors.kernel.org/ubuntu/pool/main/b/b43-fwcutter/b43-fwcutter_019-2_amd64.deb should be installed or the i386 alternative.

  • Hi, I did everything you said. Downloaded mirrors.kernel.org/ubuntu/pool/main/b/b43-fwcutter/…, because i have 32 bit i686 arhitecture. After downloading lwfinger.com/b43-firmware/broadcom-wl-5.100.138.tar.bz2, I copied those two files in home folder, then run: sudo dpkg -i b43-fwcutter_015-9_i386.deb, tar xfvj broadcom-wl-5.100.138.tar.bz2, sudo b43-fwcutter -w /lib/firmware broadcom-wl-5.100.138/linux/wl_apsta.o, and rebooted, nothing changed, actually I got an error saying my installed pckg have unmet dependencies. – ZaZen Apr 6 '18 at 9:35
  • Use these commands to solve dependency problem.sudo apt-get update –fix-missing; sudo dpkg --configure -a; sudo apt-get install -f; – Dipankar Nalui Apr 6 '18 at 9:57
  • Please read this askubuntu.com/questions/146150/… – Dipankar Nalui Apr 6 '18 at 10:02
  • Sorry it took me so long to answer, anyway, after solving dependency problem wifi is still not working.. I tried to install lubuntu willy 15.10 (from my old 2016 .iso file), but the wifi was disabled there also, even though it worked on that lubuntu as i said before... – ZaZen Apr 12 '18 at 11:06
  • Would you suggest completely wiping off my hard drive including currently installed lubuntu 16.04 and start all over again? It is an old laptop which I actually don't need (but a good piece of hardware), and there are no files on hard drive... So I can't lose anything.. – ZaZen Apr 12 '18 at 11:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.