i have a NVIDIA GeForce 1050 Ti graphic card. I'm running LiNux Mint 18.3 when i try to install the .run file it fails. It shows the message like this:

ERROR: Your appear to be running X server; please exit X before installing. For further details, please see the section INSTALLING THE NVIDIA DRIVER in the README available on the Linux driver download page at www.nvidia.com

1 Answer 1


How to install NVIDIA.run?

As the error states, you are still running an X server. This error occurs when you try to install the Nvidia .run files while logged in.

Make sure you are logged out.

  1. Hit Ctrl+Alt+F1 and login using your credentials.
  2. kill your current X server session by typing sudo service lightdm stop or sudo lightdm stop
  3. Enter runlevel 3 by typing sudo init 3
  4. Install your .run file. you change to the directory where you have downloaded the file by typing for instance cd Downloads. If it is in another directory, go there. Check if you see the file when you type ls NVIDIA Make the file executable with chmod +x ./your-nvidia-file.run Execute the file with sudo ./your-nvidia-file.run
  5. You might be required to reboot when the installation finishes. If not, run sudo service lightdm start or sudo start lightdm to start your X server again.
  6. It's worth mentioning, that when installed this way, you'd have to redo the steps after each kernel update.
  • -> The distribution-provided pre-install script failed! Are you sure you want to continue? (Answer: Continue installation) ERROR: The Nouveau kernel driver is currently in use by your system. This driver is incompatible with the NVIDIA driver, and must be disabled before proceeding. Please consult the NVIDIA driver README and your Linux distribution's documentation for details on how to correctly disable the Nouveau kernel driver. Apr 5, 2018 at 9:03
  • askubuntu.com/questions/841876/…
    – Dipankar
    Apr 5, 2018 at 15:28
  • If this answer solves your problem, please accept the answer by clicking the answer button. Or, If you would have solved by yourself, please share the solution. Thanks.
    – Dipankar
    Apr 6, 2018 at 6:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.