0

I built the glibc-2.11 with arm-none-linux-gnueabi version 4.4.1. And I copy binaries to my board's rootfs. When I type "ldconfig", I met following errors.

**ldconfig: Can't open configuration file /home/gykim/working/s1cam/gykim/stream/bsp/linux/util/glibc-2.11/_install/etc/ld.so.conf: No such file or directory
ldconfig: Can't create temporary cache file /home/gykim/working/s1cam/gykim/stream/bsp/linux/util/glibc-2.11/_install/etc/ld.so.cache~: No such file or directory**

My configure options as follows.

*../configure --host=arm-none-linux-gnueabi --enable-add-ons=../glibc-ports-2.11,nptl,libidn CFLAGS='-O3' --prefix=/home/gykim/working/s1cam/gykim/stream/bsp/linux/util/glibc-2.11/_install*

Actually, I want to change these path to /etc/ without don't modify prefix. How can I change this path?

0

I found it by myself. Add following in the config.make.in file.

install_root = *$(DESTDIR)*

And type DESTDIR=*install_dir* in the command line.

$ ../configure ~~~
$ make
$ make install DESTDIR=${DESTDIR}

Then, the install directory is DESTDIR, and system dir is prefix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.