1

So basically my problem is the following: after I suspend my notebook and resume my internet gets really laggy, for example sites take much longer to load or fail to load, twitch.tv cannot properly buffer video, etc. I also performed a speed test (ookla) and the results were 4 times less than my normal speed (it was 16Mb to local provider when my normal rate is 100Mb) and even so, when I monitor my connection through iftop it's usually like 200kb after resume. Also I checked ping and it reported 0-5% package loss without almost any 'time' changes.

The only thing that helps is rebooting my router, which is really weird. I also tried: rebooting the notebook, restarting NetworkManager.service, dhcpcd.service, reconnecting via GUI, disconnecting my Ethernet->usb dongle and connecting it back with service restart but to no avail.

I tried looking into journalctl and dmesg but didn't see any relevant info. I have seen a few ipv6 errors, hence tried disabling it, but it didn't help. I've had this problem for a week or so now, maybe some package update just broke it but not sure.

Also, I've had a few (rare) situations where kernel just froze (task scheduler blocked for more than 120 seconds) where I couldn't do almost anything, not even shutdown properly. Looking through logs later on it seems to me that network drivers were involved (based on stacktrace in logs), maybe even dongle drivers because one time it happened when I was messing around with my connection.

My configuration:

Asus zenbook 16GB RAM, i7-7700hq, 1050ti but no drivers installed and nouveau blacklisted (I use intel graphics because X server couldn't load properly with either nouveau, nvidia drivers or bumblebee) with Arch linux + KDE + SDDM

Internet connection via Ethernet->Usb dongle

dongle: 
  0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter)

uname -a
  Linux neko 4.15.14-1-ARCH #1 SMP PREEMPT Wed Mar 28 17:34:29 UTC 2018 x86_64 GNU/Linux

NetworkManager -V
  1.10.6-3, Arch Linux

If you need any other info I'll be happy to give it.

  • You said the only thing that helps is rebooting the router: does that mean if you have a normal connection, suspend Arch Linux, awaken it to the poor connection, and then reboot Arch Linux, the problem still persists? If so, this problem may be quite complex. – aliceinpalth Apr 3 '18 at 22:44
  • I believe it will go away if I reboot my notebook because I've never had this issue after boot. But I'll check it tomorrow to be sure. – lundibundi Apr 3 '18 at 22:54
  • How much ram do you have are you sleeping to ram or swap? what does htop shows? – vfbsilva Apr 3 '18 at 23:28
  • @vfbsilva I have 16 GB of ram and use default suspend (which is suspend to ram). I'm not seeing anything abnormal in htop. Should I be looking for something specific? – lundibundi Apr 4 '18 at 5:15
  • @aliceinpalth ok, I've checked reboot and it seems that the problem is still there unfortunately =( – lundibundi Apr 4 '18 at 5:25
0

So for those interested, I have solved the problem as follows.

I've found a few threads on linux mailing lists and other distro forums about rtl8153 and its driver problems and also info that there are 2 drivers cdc_ether and r8152, where the former one is generic and latter is rarely used, hence I tried to change the driver used for my device to r8152 (with the help of this article, fortunately I already have r8152 in my system so there was no need to download or install anything).

I did this as follows: Added a file to /etc/modprobe.d/rtl_usb.conf with contents

alias usb:v0bdap8513d*dc*dsc*dp*ic*isc*ip*in* r8152

proper line you can get from article, basically its the same as above but

Note: You must change the vID and pID according to your USB NIC, for me it's 0bda and 8513 for this particular adapter.

You can get those values from lsusb where you find your adapter and then the first 4 symbols after ID is vID and next after the colon is pID.

Then you should run sudo depmod -a to update kernel module dependency file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.