19

I have a mouse with a weird problem. The left button sometimes fires a double click even if I click just one time.
I would like to know if there's a way to avoid fast double clicks, ignoring clicks with an interval lower than a defined value.
I'm using Fedora 15.
Thanks in advance.

11
  • 18
    The mouse is supposed to do that already: it's called debouncing. It sounds like the switch is worn out and is bouncing a lot; it might be easiest to just get a new mouse.
    – Wyzard
    Jul 19, 2012 at 23:54
  • 3
    Not a real answer to your question, as it's not a software solution, but when a mouse of mine becomes old enough to exhibit such behaviour, I tend to open it up, swap the left-button microswitch with that of a button I use less often (means desolder, swap, resolder), and reassemble the casing.
    – MvG
    Jul 23, 2012 at 17:04
  • 2
    Same here. Don't even try to fix hardware-problems with software. Nov 13, 2012 at 22:23
  • 8
    @BonsiScott You can't fix hardware problems with software but you can compensate for them.
    – David
    May 22, 2013 at 20:35
  • 1
    Rather than desoldering microswitches, you could try fixing them in-situ like this Apr 1, 2019 at 2:15

4 Answers 4

12

I found this:

https://aur.archlinux.org/packages/xf86-input-evdev-debounce/

after googling for "linux xinput mouse debounce"

I'm not gonna test it. It's been a long time since you asked, but maybe someone has the same problem with a favorite mouse, so here it is. Also, I'm not an Arch user; but they really rock!

5
  • 2
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes.
    – jordanm
    Oct 18, 2014 at 3:59
  • 2
    @jordanm What do you mean by "include the essential parts of the answer"? Shall the user include the source code? It's a link to a piece software.
    – pfnuesel
    Dec 19, 2014 at 20:10
  • 1
    I tried this piece of software and it works well for me. Fixed my double clicking problems. This answer is a gem.
    – pfnuesel
    Dec 19, 2014 at 20:10
  • I've tested it and reported here: askubuntu.com/a/616956/6820. In short, it's a good fix unless the contact is TOO bad. May 1, 2015 at 16:23
  • @pfnuesel In this case, I would say that "include essential parts" would translate to explaining what it does and how to use it.
    – Hjulle
    Apr 12, 2016 at 11:51
3

As I posted in this answer, this should be fixed with libinput 1.9.

Announce:

Pointer devices now have button debouncing automagically enabled. Ghost button release/press events due to worn out or bad-quality switches are transparently discarded and the device should just work.

1

A small fix to libinput patch (proposed by @Victor Sergienko) that is reported as "failing to apply" to new libinput versions by some users (https://bugs.freedesktop.org/show_bug.cgi?id=11833).

https://pastebin.com/raw/qa6UP1k1

0

you can try the option

Double-Click Timeout

in mouse preferences, like this http://beginlinux.com/desktop/fedora/mouse-preferences

1
  • 4
    This option specifies the the longest possible interval between two clicks to be detected as a double click but the OP needs to specify the shortest possible interval. I have never seen such an option. Sep 22, 2014 at 12:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .