1

I recently attached a SSD to my system, with the old HDD in the DVD drive bay I set up the file mount option in the /etc/fstab file.

The permissions are as follows for SSD:

/dev/sda2   /home/arun/SSD/     auto rw,user,nodev,nofail,x-gvfs-show   0 0

for HDD

/dev/sdb2   /home/arun/HDD/     auto rw,user,nodev,nofail,x-gvfs-show   0 0

The differnce is the HDD do not give me any write permissions unless i am operating as root.

What I tried:

  1. using 'sudo chmod 777 /home//HDD' to change the permissions. command passes correctly but nothing reflects in action(root permission still needed), file permissions do not get a 'w' when i do 'ls -l'

  2. using 'sudo chown /home//HDD' , error: operation not permitted.

I was able to write to this HDD, before I cleaned both my disks and Installed the operating system Ububntu 16.04 LTS.

both the commands were run recursively and non-recursively.

Can This be due to the fact that I installed it in the DVD drive bay? Do I need to change something in the BIOS setting?

  • 1
    Post the output of lsattr /home/arun/HDD. Also, it may be better to create anSSD and HDDdirectory in /mnt and change your /etc/fstab to mount the drives there rather than mounting them in your home directory. – Nasir Riley Apr 1 '18 at 17:38
1

run from root this command:

chown -R arun:arun /home/arun/HDD 

and after try to write something in it.

  • already tried, same error: operation not permitted – ArunMKumar Apr 1 '18 at 17:29
  • 1
    is that an fat16 or fat32 or exfat filesystem? if yes they can't handle permissions. – D'Arcy Nader Apr 1 '18 at 17:36
  • 1
    NTFS won't take the permissions either. – Nasir Riley Apr 1 '18 at 17:55
  • yes you are right, you have to set permission on mount. something like this : /dev/sda2 /home/arun/HDD/ auto rw,user,fmask=0022,dmask=0000,nodev,nofail,x-gvfs-show 0 0 – D'Arcy Nader Apr 1 '18 at 18:14
  • thanks @D'ArcyNader it was a FAT32 partition, now formatted to ext4. problem gone now. – ArunMKumar Apr 24 '18 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.