I'm currently running fedora 27 on an Acer Aspire Switch One SW1-011 (https://www.notebookcheck.info/Acer-Aspire-Switch-One-10-SW1-011-11AN.231024.0.html)

according to that link it's a Realtek RTL8723BS

 

uname -a:

Linux localhost.localdomain 4.15.12-301.fc27.x86_64 #1 SMP Thu Mar 22 19:25:27 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

 

When running lshw -C network it returns only my usb-ethernet adaptor

  description: Ethernet interface

   physical id: 1
   bus info: usb@1:3.1.2
   logical name: enp0s20u3u1u2
   serial: 00:e0:4c:36:0d:e4
   size: 100Mbit/s
   capacity: 100Mbit/s
   capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8152 driverversion=v1.09.9 duplex=full ip=192.168.0.102 link=yes multicast=yes port=MII speed=100Mbit/s`

 

lspci returns:

00:00.0 Host bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register (rev 22) 

00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers (rev 22)

00:03.0 Multimedia controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Imaging Unit (rev 22)

00:0b.0 Signal processing controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Power Management Controller (rev 22)

00:14.0 USB controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller (rev 22)

00:1a.0 Encryption controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine (rev 22)

00:1f.0 ISA bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU (rev 22)

 

lsmod | grep 8723 returns:

r8723bs               704512  0

cfg80211              733184  1 r8723bs

mmc_core              172032  4 sdhci,mmc_block,sdhci_acpi,r8723bs

I've additionally also tried adding blacklist acer_wmi into /etc/modprobe.d/blacklist.conf without any luck

It possible that the hardware is fully proprietary or just block.

lspci -k

-k option show kernel driver handling each device as explain in the manual

then

rfkill unblock all && rm -rf /dev/rfkill && reboot

That will unblock all things from rfkill that could be block by default

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.