1

I'm running archlinux with ttf-google-fonts-git package installed, so I have a lot of monospaced fonts like Noto Mono, Hack, Insonsolata, Consolas, etc. But, when I open any qtwebengine based browser(qutebrowser, falkon, zeal to read docs) or chromium, code blocks doesn't render correctly. Take a look at the screenshot from github:

incorrect monospace rendering

But at some pages it looks good, include stackowerflow:

correct rendering

I tried to follow instructions and advices from this reddit post, also other sources that I googled but without success.

fc-match output is:

~ > fc-match monospace
NotoMono-Regular.ttf: "Noto Mono" "Regular"

Firefox renders all good, but I want to solve this issue anyway. Thanks

  • Use the Inspect tool in the Chromium browser to determine what font was originally requested. Also, check the chrome://settings/fonts page to be sure that the Fixed-width font is actually a monospace one. – contemplator Apr 5 '18 at 17:53
  • Thank you so much! I have inspected elements and have found that on github.com the first font family in list is SFMono-Regular, then comes Consolas(which I have installed) and, finally, monospace(which is set to Noto Mono in settings). So, I have ended up installing Apple fonts SFMono(with a little trick - edited font name in FontForge to SFMono-Regular), Menlo, Monaco. Now rendering is fine, but anyway it feels not so right, I mean installing new fonts when browser should use existing system font instead of non-existing. Thanks. – Vladimir Shabunin Apr 5 '18 at 22:29
  • 1
    You can create aliases in fontconfig (wiki.archlinux.org/index.php/…), no need to copy the font files. What does fc-match "SFMono-Regular" say in your original configuration? – contemplator Apr 6 '18 at 16:57
  • It says: SFMono-Regular.otf: "SF Mono" "Regular". Thanks for info about aliases. Missed it when was reading manuals. – Vladimir Shabunin Apr 24 '18 at 19:16
0

I solved it by removing Noto Sans CJK JP & Noto Serif CJK JP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.