0

I'm trying to mount an external HDD to an ARM server running Debian Jessie. I removed the partition and made a new one in parted with mkpart primary ntfs 0% 100%. Below is the output from sudo fdisk -l relevant to the disk and the output when I tried mounting it. Distro and all packages are up-to-date. What am I doing wrong here?

Disk /dev/sda: 7.3 TiB, 8001563221504 bytes, 15628053167 sectors 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: BC80D810-2ABA-4F4D-B552-B3017B3AE61A

Device     Start         End     Sectors  Size Type
/dev/sda1   2048 15628052479 15628050432  7.3T Microsoft basic data

root@odroid-jessie:~# mount -t auto /dev/sda1 /media/USBHDD1
mount: wrong fs type, bad option, bad superblock on /dev/sda,
   missing codepage or helper program, or other error

   In some cases useful info is found in syslog - try
   dmesg | tail or so.
root@odroid-jessie:~# dmesg | tail
[  378.407567] [c3] sd 2:0:0:0: [sdb] Mode Sense: 4f 00 00 00
[  378.408174] [c3] sd 2:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[  378.418366] [c3] sd 2:0:0:0: [sdb] Very big device. Trying to use READ CAPACITY(16).
[  378.505027] [c3]  sdb: sdb2
[  378.512752] [c3] sd 2:0:0:0: [sdb] Very big device. Trying to use READ CAPACITY(16).
[  378.520375] [c1] sd 2:0:0:0: [sdb] Attached SCSI disk
[  822.494479] [c1] sd 1:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[  822.574393] [c2]  sda: sda1
[  840.166662] [c3] sd 2:0:0:0: [sdb] Very big device. Trying to use READ CAPACITY(16).
[  840.243315] [c3]  sdb: sdb1
  • Is ntfs-3ginstalled? – Nasir Riley Mar 30 '18 at 15:08
  • @NasirRiley Yes – Zenon Mar 30 '18 at 15:58
3

When you create a partition, it does not add a file-system.

You need to add a file-system, also.

mkfs.ntfs /dev/sda1 (double check device, if you get it wrong, then you will lose data).

There are partition tools that do both partitioning and creation of file-system.

  • I thought parted did this when you specify a fs type. – jordanm Mar 30 '18 at 15:23
  • @jordanm Some partition editors do, some don't. The actual partition editing does not do it. However some programs do both. So will depend on what program you use. – ctrl-alt-delor Mar 30 '18 at 15:30
  • I thought parted did this as well. It even asked for filesystem type when I created a partition on another disk; for this one, I specified the filesystem in the command. I’ll try running this when I get home. – Zenon Mar 30 '18 at 16:00
  • This worked, but it took 32 hours. I now know to use the -f flag next time. Thank you! – Zenon Apr 1 '18 at 21:33
  • 32 hours (Wow). – ctrl-alt-delor Apr 1 '18 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.