I ran my debian install wirelessly. I "just" selected wifi card, then ssid, encryption, password. Then selected dhcp, not fixed addresses.

Network connected, finished install over network.

After boot into new system, I expected network to be working over wifi, just as it is when I install over Ethernet: The settings used on install is the settings used in running system.

Apparently it's not so with wifi; I have to fiddle with wpa_supplicant etc. Or is there a simple way to start wifi with the installer-used settings?


During install, /target/etc/network/interfaces contain

# The primary network interface
allow-hotplug wlp4s0
iface wlp4s0 inet dhcp
# This is an autoconfigured IPv6 interface
iface wlp4s0 inet6 auto
    wpa-ssid MYSID
    wpa-psk  MYPASSWD

but after install it doesn't contain references to the wifi interface. I saved the file during installation, and used it after install. It works, but ...

  • I get a link IPv6 after 30 sec
  • I get a global IPv6 after 1 minute
  • I get a DHCP IPv4 after 7 minutes.


If I remove the inet6 auto line from /etc/network/interfaces

allow-hotplug wlp4s0
iface wlp4s0 inet dhcp
    wpa-ssid MYSSID
    wpa-psk  MYPASS

I get and IPv4 AND IPv6 so fast it is already ready if I log in as fast as possible after boot.

  • That’s odd, the settings should have been preserved. What does /etc/network/interfaces contain? – Stephen Kitt Mar 30 '18 at 13:46
  • /etc/network/interface contain only lo and Source /etc/network/interfaces.d/ which is empty. I didn't select graphical desktop, I only need a headless server, but I installed using the graphical installer. I'll try reinstalling using the curses installer. – Lenne Mar 30 '18 at 14:07
  • Well, 25% into a curses-based install /target/etc/network/interfaces contain the setup for the wifi. So I have saved a copy in case it gets overwritten. – Lenne Mar 30 '18 at 14:25
  • It did get overwritten. So I copied the one used under install, and I then get a link local ipv6 after 30 sec, and a global after a minute. But getting a dhcp ipv4 takes 7 minutes! I'll edit the file into the question for formatting reasons. – Lenne Mar 30 '18 at 15:34
  • 1
    I have to type it manually, so I'll just say it's a Qualcom AR9285/Subsystem Azurewave AW-NE785. I don't have a rfkill command. – Lenne Mar 30 '18 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.