0

I tried to copy the entire arch install onto another hard drive (form HDD [/dev/sda] to SSD [/dev/sdb], both internal).

This is how I tried to do it:

  • Live Arch stick
  • mounted both root partitions
  • cp -a /mnt/HDD/* /mnt/SSD
  • same for boot and efi partition
  • chrooted into SSD
  • reinstalled grub
  • run grub-install
  • updated /etc/fstab

Everything seemed to work, but the SSD system is not displayed in my computer's EFI. What do I do wrong?

Thanks in advance!

EDIT:

@Paul H.'s way to install grub now worked!

The only problem is that both EFI entries boot the same OS, which is the old (HDD, /dev/sda4) one...

  • How did you create the efi partition on the new drive? Was it formatted FAT32? And what options did you run grub-install with? – Paul H. Mar 30 '18 at 14:01
  • @PaulH. Yes. I created a 500 MB partition using fdisk, fomatted it as EFI partition and run mkfs.fat /dev/sdb3. The file system should be correct, as it displays it as vfat when running genfstab – Alexander Schoch Mar 30 '18 at 14:04
  • @PaulH. and I run grub-install without any options, and it told me that it was a x86_64-efi install. – Alexander Schoch Mar 30 '18 at 14:06
  • You could try installing grub with the options here. – Paul H. Mar 30 '18 at 14:09
  • @PaulH. I ran grub-install --target=x86_64-efi --efi-directory=/dev/sdb3 --bootloader-id=arch_grub and got grub-install: error: failed to get canonical path of /dev/sdb3'.` – Alexander Schoch Mar 30 '18 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.