2

I have a rather peculiar problem. I've been using a user cronjob calling fetchmail to receive mail from 6 IMAP accounts for about two months. It is set up to forward mail to procmail, which then sorts it into a number of mailboxes, then I used to read it with mutt.

This worked fine until Marh 8th, when suddenly fetchmail would still retrieve mail, but mail from 5 out of the 6 accounts would simply disappear. It would neither appear in /var/spool/mail/my-username nor in the procmail logfile, though the fetchmail logfile reports it's happily retrieving messages.

I can telnet to localhost:25, am not running from root and have not consciously set up any alias or forward options and did not make any system updates around the date. My system is Fedora 27. The working account is the last one in the .fetchmailrc, if that's of interest.

  • Have you tried to make fetchmail execute procmail directly? see mda configuration option. – AnFi Mar 30 '18 at 17:49
  • Sorry for taking so long - you may guess I have a mail problem. I set up mda "/usr/bin/procmail", and it had worked flawlessly this way for months – waechtertroll May 2 '18 at 6:33
1

Before the erratic behaviour, I had set up an mda ... line at the end of my .fetchmailrc, and for some reason I don't know yet, this was applied to all of my accounts.

The problem I experienced was fetchmail falling back to its normal behaviour - the mda was set as last line, so it was applied only to the last account in the rc-file.

Not sure how it ever worked before, but after adding an mda instruction to every account entry, all mail is fetched and forwarded properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.