2

I've replaced my backup server and I switched from a Debian Stretch to a CentOS7. I have a SuperLoader 3 LTO4 SCSI on an old adaptec SCSI 160. At first, I had to use the CentOSplus kernel which add the old SCSI aic7xxx module to have my hardware detected.

It's working, but I have a top speed to 2MB/s while I do a "btape speed" test.

I've also tried with another SCSI controller 320; this one is natively supported by the CentOS kernel. Same issue; I tried to boot Debian on the same hardware and at this moment, I get the max speed.

Right now, I'm pretty sure it's a kernel issue. Do you know if there're any settings to avoid this issue?

Edit 17/04/18 : On tapestat i see i have a 99% write time wait, is it why it's so slow ? Any idea ? I'm starting to lose hope :(

  • 1
    May or may not be related to your problem, but worth a try: I recently had I/O throughput issues, and it turned out that clearing the I/O cache with echo 3 > /proc/sys/vm/drop_caches solves at (at least for some time). I suspect some multicore concurrency problem related to caches, but haven't tracked it down yet. – dirkt Mar 29 '18 at 13:58
  • Nope, not better, maybe worst, i have 600Kb/s with the last test drop_caches set at 3 – makz Apr 3 '18 at 6:54
  • @makz Check if the drive buffer has been turned off for some reason. Try mt drvbuffer 1 to turn it back on. I had this problem, too. It is also possible that your SCSI controller doesn't like tape drives, but I see you have already tried a different one. – FUZxxl Apr 3 '18 at 14:55
  • @FUZxxl not better, right now it's the same SCSI card i used in the other server and as i said, if i boot a debian on the same hardware, i have full speed. I'm sure it's a CentOS issue. – makz Apr 4 '18 at 12:55
  • @makz Hm... that's a possibility. No idea what the reason is. – FUZxxl Apr 4 '18 at 13:00
1

Sooo, after a discussion with another system engineer. We figured it could be the meltdown patch which is in fault here.

Because it's a old pcix controller, the driver structure may trigger the KPI and slow down/limit the throughput.

I tried by disabling the pti on the current kernel but no improvement, maybe there's other patchs we can't disable.

The best option but i can't is to install a kernel pre-meltdown to see if it help.

but i decided to go on a pci express scsi controller and it fixed my issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.