7

This question already has an answer here:

Getting error message at logon "session only lasted less than 10 seconds....", which apparently can be caused by multiple issues. My error is happening during the graphical logon.

I can login to the console by pressing ctrl alt F1. contents of ~/.xsession-errors file indicated that initctl was unable to connect to upstart. The message says that this process is looking for a socket at /com/ubuntu/upstart which is an invalid path on my system.

I created a new user to see if there was an issue with any profile configuration, but the new user graphical logon session also lasted less than 10 seconds for the same reason.

I've updated, upgraded, dist-upgraded, and autoremoved, but no change. I"ve confirmed that cinnamon is fully installed.

I'm running linux mint 18 sarah cinnamon 64-bit. Prior to the 10 second error, all video programs VLC media player and totem player failed to start & reinstall of those packages didn't fix. I rebooted & discovered I had much bigger problem.

I thought that the path initctl was looking for was the wrong one: (/com/ubuntu/upstart) since that file system path doesn't exist.

I used grep & strings to locate another occurrence in lib/sysvinit/telinit. In addition to /com/ubuntu/upstart, I also noted "linux:abstract=/com/ubuntu/upstart. google to http://man7.org/linux/man-pages/man7/unix.7.html said: Linux also supports an abstract namespace which is independent of the filesystem. So I guess this will take more than locating the offending config file & making a change.

So now I'm really in over my head! Anyone have a suggestion on how to fix this?

one last hail mary: removed virtualbox-guest-x11 & rebooted and my system is back. I had previously removed virtualbox package because I noticed it had updates today, but I didn't realize that there was another package included in the offending update.

and it only took 7 hours to fix....... I'm going to post this "question" anyway in case it helps someone else.

marked as duplicate by JdeBP, G-Man, Hauke Laging, elbarna, don_crissti Mar 30 '18 at 15:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    This question should not be protected, this is a major issue whereby updating virtualbox makes Mint machines inaccessible (I've seen 4 cases of this personally), please unprotect it. – J.J. Green Mar 27 '18 at 9:39
  • This question demonstrably should be protected, given that the thing described in the protection notice (q.v.) has already happened. There are four times as many deleted non-answers here, where people have simply abused the "Your Answer" box, than attempts at actual answers. The same has already happened at one of the linked questions, too. – JdeBP Mar 28 '18 at 7:43
8

I had the same problem and this solution worked for me. To remove the package, press Ctrl+Alt+F1 and log in. Then run:

sudo dpkg -r virtualbox-guest-x11

Now reboot and enjoy

  • 2
    You saved my day! Thanks! Btw. I don't know why this package was installed on my host – Ingemar Mar 27 '18 at 4:55
  • Worked for me, I did a full apt update yesterday. Something broken in this package? – Gijs Mar 27 '18 at 9:11
  • Yes, the Linux Mint team acknowledged that this package broke Cinnamon, and has since released an update to mintupdate to mend this. – xjcl Apr 1 '18 at 14:27
  • If anyone is experiencing a slow-feeling Cinnamon after this fix, you might have accidentally selected "Cinnamon (software rendering)" (C2) instead of "Cinnamon" (Ci) at the login panel. To fix: Log out, select "Ci", and log in again. – xjcl Apr 1 '18 at 14:30
  • Running under VirtualBox this solved my problem. I then add to re-install the guest additions CD to restore hardware rendering. – Jack Aidley Aug 29 '18 at 10:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.