0

I have this issue, I try to run ./MadCoin-qt it's wallet and i receive this errror:

./MadCoin-qt: error while loading shared libraries: libminiupnpc.so.8: cannot open shared object file: No such file or directory

I run ldd ./MadCoin-qt

linux-gate.so.1 (0xf7733000)
    libminiupnpc.so.8 => not found
    libssl.so.1.0.0 => not found
    libcrypto.so.1.0.0 => not found
    libdb_cxx-5.3.so => not found
    libboost_system.so.1.54.0 => not found
    libboost_filesystem.so.1.54.0 => not found
    libboost_program_options.so.1.54.0 => not found
    libboost_thread.so.1.54.0 => not found
    libQt5PrintSupport.so.5 => not found
    libQt5Widgets.so.5 => not found
    libQt5DBus.so.5 => not found
    libQt5Network.so.5 => not found
    libQt5Gui.so.5 => not found
    libQt5Core.so.5 => not found
    libpthread.so.0 => /lib32/libpthread.so.0 (0xf76e3000)
    libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf7567000)
    libm.so.6 => /lib32/libm.so.6 (0xf7512000)
    libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf74f4000)
    libc.so.6 => /lib32/libc.so.6 (0xf733d000)
    /lib/ld-linux.so.2 (0xf7735000)

How to install libminiupnpc.so.8?

  • 1
    Well, it's a bit more than just that library. It seems to depend on Qt and boost and other libraries that also are not installed. – Kusalananda Mar 26 '18 at 18:16
  • since you're not using a repository with package resolution, you'll have to do it yourself. Starting from this URL debian.org/distrib/packages#search_contents . Good luck PS: looks that this requires Debian 8 aka jessie aka oldstable packages (not current Debian 9 aka stretch aka stable) – A.B Mar 26 '18 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.