0

I'm using VNC Viewer 5.3.2 (r19179) x64 on a Windows 10 machine to connect to a VNC Server (Virtual Mode) 5.3.2 (r19476) x64 running on SUSE Linux Enterprise Server 11. My issue is concerning copy and paste.

I'm aware that Linux have two different clipboard, PRIMARY and CLIPBOARD. If I select some text, it get sent to PRIMARY and I may be able to paste it using the third button mouse, or using SHIFT+INSERT. However, selecting text should not override the CLIPBOARD. CLIPBOARD is used when user is selecting text, THEN copying it using CTRL-C or right-click copy. After this, if I paste using CTRL-V, it should paste what reside in CLIPBOARD, no matter if I selected some text (altered PRIMARY) between the copy and paste operation.

When I connect to my remote machine using VNC, all this is working perfectly fine: I can copy some text with CTRL-C, then select anything and paste with CTRL-V to paste what I copied with CTRL-C. However, if I copy some text outside VNC Viewer, i.e. some text in a Notepad on my local machine (Windows 10) then select some text in my remote machine (SLES 11) and try to paste it over, it paste what I just selected, even if I use CTRL-V.

At this moment, PRIMARY and CLIPBOARD get messed up up in my remote machine until I close the session and open a new one. This means, if I select some text and do a CTRL-V, it paste the text I just selected. This become really annoying since if I want to copy something then paste it over something else, the system paste what I just selected and I loose the CTRL-C I just made. I don't know whether the selected text gets send to CLIPBOARD or PRIMARY or if the CTRL-V is now pasting from PRIMARY or CLIPBOARD, but there is something messed up.

I'm aware VNC Viewer used to have an option called SendPrimary which could potentially resolve my issue (see this), but I can't find this option in VNC Viewer 5.3.2.

0

Just got the answer from the Real VNC team. Apparently the SendPrimary options was only available in Linux VNC Viewer version. However, lastly, it has been moved to VNC Server. So to disable the SendPrimary option, you have to add the following line to .vnc/config.d/vncserverui-virtual:

SendPrimary=0

If you want to disable it globally, add it to /etc/vnc/config.d/common.custom.

Edit: Please note that you need to restart VNC Server for this to take effect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.