1

I'm trying to install GAMESS (a computational chemistry package) on a Linux Mint machine and the config file has a #!/bin/csh at the beginning.

When I run ./config the first line is export: Command not found. If I try to go on with the installation process I get a lot of other ''Command not found'' lines.

I have already installed csh and tcsh and this is the output of echo $PATH:

/home/chicolucio/Gabedit64:/home/chicolucio/anaconda3/bin:/home/chicolucio/bin:/home/chicolucio/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/usr/lib/jvm/java-8-oracle/bin:/usr/lib/jvm/java-8-oracle/db/bin:/usr/lib/jvm/java-8-oracle/jre/bin

''chicolucio'' is the user.

I tried to change the first line of the file to #!/bin/tcsh (the readme file cite this as an option when having problems with the interactive installation) but it didn't work. I also tried to run dos2unix on the file based on some links I read on internet but it also didn't work. Both attempts yields the same ''Command not found'' issues.

What else can I try? I'm kind of new on Linux.

  • export is more typical to /bin/sh maybe try that instead? – thrig Mar 26 '18 at 3:59
  • There are several variants of this closed source software, with decades of divergence between some of them. Which one are you using? – JdeBP Mar 26 '18 at 7:03
  • @JdeBP GAMESS version September 30, 2017 R2 for 64 bit (x86_64 compatible) under Linux with gnu compilers (text from the e-mail they send me when I request the program) – chicolucio Mar 26 '18 at 10:58
  • @thrig I think that this could cause problems because the readme recommends csh or tcsh. Apparently because of the interactivity process (a lot of questions asked during install). But thanks, I'll try this if no csh or tcsh attempt works. – chicolucio Mar 26 '18 at 11:23
2

I noticed that I actually have access to this software and the config file is a csh script (so #!/bin/csh is correct). My copy of this file has a date in it saying "5 Dec 2014". However, if your config file has export commands in it, then it is either modified or it is an updated version (with the wrong #!-line).

You should also investigate whether you have a ~/.cshrc file that contains export commands (this would be an error). The ~/.cshrc file for csh corresponds roughly to ~/.bashrc for bash.

  • Note, though, that there are at least three variants of the software, some with divergence points that come close to pre-dating the C shell. – JdeBP Mar 26 '18 at 6:58
  • @Kusalananda your answer seems to be in the right way. The only line I got on the ~/.cshrc is set path='$HOME/Gabedit64 $path'. Gabedit is another computational chemistry software and I think that line was added by the software installation process. I rename this file with .old and clear the file. Now, with the blank ~/.cshrc file, GAMESS installation works. The Gabedit seems to be working too. However, what does that line mean? Is there any chance that the Gabedit software stops working if I go on with the blank file? – chicolucio Mar 26 '18 at 11:16
  • @chicolucio I can't immediately see how setting the path in the ~/.cshrc file might provoke the shell to run an export command. – Kusalananda Mar 26 '18 at 12:53
  • @Kusalananda OK. I'll mark your answer as the accepted answer because it solved my installation problem. I also don't know why that line on the file cause this, I'll try to restore the file later and try again to see if the problem repeats. Thank you! – chicolucio Mar 26 '18 at 19:15
  • 1
    @Kusalananda I think that I found out what the problem was. The syntax for csh seems to be different from bash. Based on some research, I rewrote the ~/.cshrc file as set path= ($path $HOME/Gabedit64). Apparently this works, no errors. – chicolucio Mar 27 '18 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.