0

I have a PC running Ubuntu 16.04.1 and I'm trying to set it up as a remote torrenting machine. I've successfully gotten OpenSSH to run on it and I can access it on port 22 from within my network just fine. I installed qBittorrent and am now trying to set up its web UI. I have it set to the default port, 8080, and when I run nmap and netcat respectively, I get:

forest@Forest-NUC:~$ nmap 192.168.1.168
Starting Nmap 7.01 ( https://nmap.org ) at 2018-03-25 18:11 PDT
Nmap scan report for Forest-NUC.fios-router.home (192.168.1.168)
Host is up (0.00027s latency).
Not shown: 997 closed ports
PORT     STATE SERVICE
22/tcp   open  ssh
1041/tcp open  danf-ak2
8080/tcp open  http-proxy

forest@Forest-NUC:~$ nc -v -z 192.168.1.168 8080
Connection to 192.168.1.168 8080 port [tcp/http-alt] succeeded!

Port 8080 shows as being open, and I can access the web UI from a chrome browser on the machine that's hosting it, but I can't access it from any other machine on my network. I've tried checking the boxes in qBittorrent for port forwarding and "Use HTTPS" to no avail. I've also tried using ports other than 8080 (such as 80 and 21) but only 8080 shows up on nmap, even after a reboot.

I've also tried having my router forward port 8080 to this computer.

I had to use:

sudo ufw allow ssh

in order to get ssh to work; do I need to do something similar in this case? Is there an exception I need to add in the firewall?

Side note: the most frustrating part is that I had it working 2 nights ago but don't know how or why it stopped working. Purging and reinstalling qBittorrent didn't do anything.

0

It's hard to tell what's the problem from your description. Maybe you can try this guide on my blog. How to Install qBittorrent on Ubuntu 18.04 Desktop or Server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.