1

I'm using Fedora 27 and recently I had a problem with the package manager of this distro, dnf, which removed the grub. Since then I can't boot my Fedora partition, it's explained in detail here :

It was Tuesday, I run the dnf autoremove command which has removed the grub2 packages. Then at the end of the day I turned off my computer. Yes I'm stupid I know. On Friday, I turned on my PC, it worked perfectly normal. But on Sunday, I try to turn it on and a beautiful blue screen appeared :

Performance MOK management 
--> Continue boot 
--> Enroll key from disk 
--> Enroll hash from disk

I try "Continue boot" and boot manager appears. It's not the usual one which is black and white, this one has a blue background :

--> Boot manager of the OS - Fedora 
--> Boot manager of the OS - Windows Boot Manager 
--> Boot from EFI file 
(Press F10 to install utility and Escape to leave)

When I try Fedora it go back to "MOK management" and it repeats. When I try Windows, it boot Windows normally. So I tried to press F10 on the Fedora option and it go to the BIOS manager, where you can change the date, the boot order etc.

I don't know what happened. Anyway I assume it's the grub. So I tried to reinstalled it. I booted on a Live USB, I followed a tutorial on a website to mount the HDD and my Fedora partition. It worked. I tried a lot of things : reinstalling grub2, undoing the bad command etc. it still doesn't work.

Can you help me ?

Important :

I don't know if we can do that and if it's allowed but I posted my problem on another forum but since it's not resolved I post it elsewhere including here to find someone who can help. Maybe someone here have a solution. The link to the other forum where I already answered some questions and made some manipulations is here.

2

You can rescue your system from the Fedora installation media (DVD/CD or USB). Boot from this media and you will see the boot screen:

Fedora rescue GRUB EFI boot menu 1

WARNING: Your system boots with EFI. If this screen appears in color then you have not booted with EFI. Reboot and start over.

Use the arrow keys to go down to Troubleshooting then press Enter. You then see this screen:

Fedora rescue GRUB EFI boot menu 2

Use the arrow keys to go down to Rescue a Fedora system then press Enter.

The media will boot and you will eventually be presented with the option to mount your system:

Fedora rescue mount question

To continue, type 1 and press Enter.

The system will mount your partitions and allow you to begin rescuing your system:

Fedora rescue, system mounted

Press Enter to get a shell, then enter the suggested command:

chroot /mnt/sysimage

You are now in your installed system and can begin repairs.

Because your system boots with EFI, you need to install (or reinstall) the EFI version of grub. The package name is grub2-efi-x64.

dnf install grub2-efi-x64

If dnf complains that it is already installed, then reinstall it:

dnf reinstall grub2-efi-x64

dnf reinstall grub2-efi-x64

This should repair your system's boot sequence. At this point just hit Ctrl+D to exit the chroot, and then again to exit the rescue shell. Your system will then reboot, and you should be able to boot into Fedora from your system's UEFI boot menu.

  • I also suggest connecting to a wired network connection while doing this repair. – Michael Hampton Mar 26 '18 at 1:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.