2

Right click has stopped working on the touchpad of my Dell XPS 13 (2015) 9343 for a few weeks now on Debian Testing (Buster). As in Wayland the libinput configuration is done through the UI (in my case GNOME) according to Arch Wiki, synaptics seems to be deprecated, and all xorg conf files seem to be ignored, I am unable to find a solution to this problem.

The only way to right click is to double tap the toucpad, and actually right clicking does simply perform a left click. Additionally, the $ libinput command returns Command not found.

4

I had a similar problem under Arch, in my case it was actually a setting being overwritten with the update of latest Gnome.

Using gnome-tweaks under Keyboard & Mouse section, Mouse Click Emulation was set to "Fingers". I turned it off and turned on the "Area" option, which uses the bottom right of the touchpad for a right click.

After this right click works as before.

  • Thank you, this solved it. I sincerely hope this feature will be added to the normal settings menu in the near future. – brickmasterj Mar 27 '18 at 12:38
0

This fix worked for me on Debian buster

gsettings set org.gnome.desktop.peripherals.touchpad click-method areas

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.