1

Few days ago I installed Antergos on my old Dell laptop with Broadcom BCM2046 Bluetooth. Since then I'm having issues with bluetooth.

First, no adapters were found. This was somehow solved (I'm not sure if I solved or maybe few restarts did the work). But now, even though bluetooth is enabled and it manages to find around some bluetooth devices it's unable to connect to them. And the main issue actually is, that systemd-udevd consumes ~100% of CPU which has clearly something to do with bluetooth cause if I disable bluetooth and restart the computer, systemd-udevd CPU consumption is only few percent.

Here is dmesg: https://pastebin.com/9NJ3ihdM And important log from it is:

[   12.957279] usb 8-2.2: usbfs: USBDEVFS_CONTROL failed cmd hid2hci rqt 33 rq 9 len 4 ret -71

Log from udevadm monitor has lots of these lines:

UDEV  [4035.892029] unbind   /devices/pci0000:00/0000:00:1d.2/usb8/8-2/8-2.2/8-2.2:1.0 (usb)
UDEV  [4036.034323] bind     /devices/pci0000:00/0000:00:1d.2/usb8/8-2/8-2.2/8-2.2:1.0 (usb)

which is probably the reason for the high CPU usage (though not the root cause)

I tried running hid2hci tool manually:

sudo hid2hci --devpath=devices/pci0000:00/0000:00:1d.2/usb8/8-2 --method=dell

But I'm getting:

Control transfer failed: Broken pipe (32)
error: switching device '/sys/devices/pci0000:00/0000:00:1d.2/usb8/8-2' failed.

Any ideas how to solve the issue?

I need to also mark that bluetooth used to work for me with Kubuntu 16.04 and KDE Neon

1

I'm on Ubuntu 18.04 with a Dell laptop (kernel version 4.15.0-20-generic) and I also had problem with systemd-udevd clogging my cpu.

I've been looking for solution all over the internet, and it seems many people with that problem have linked it to some bluetooth package "bluez" (seems that it is a specific Dell issue, and only with newer kernels).

In my case I don't need bluetooth so I just removed the package and ran sudo systemctl restart systemd-udevd

CPU load is normal since then!

-1

I'm running a Dell Latitude e4300. I found the high cpu problem went away when I disabled onboard blutooth in the BIOS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.