-1

I'm having trouble installing Linux Mint 18.3. When I get to the partitioning, it asks where to install the bootloader. In the drop-down it doesn't show my windows boot manager. I'm stuck at this point and have not advanced any further to avoid problems that I cannot fix. Any help would be greatly appreciated. The pic doesn't have the partitions setup yet as I can make them easily, plus I did this on another pc but it was much older and a BIOS.

I think the 16mb drive is actually the WBM.

The Desktop currently is an MSI motherboard, UEFI set to UEFI+Legacy.

current stateenter image description here

1

So here's what I did to fix this.

To anyone who has an issue when installing Linux Mint 18.3 alongside Windows 10, read on.

My particular issue was when I would boot the live USB in UEFI+legacy with Windows 10 pre'installed, I would click the install button. Then go through the steps, setup the partitions for /, home, and swap; all was good. Then I had to select where to install the bootloader to. This was my big hang up. The drop-down wouldn't show the WBM/reserved boot partition. All options were unlabeled or blank except for the main drive, /SDA.

"Actual CURE": What I had to do was: Boot back to Windows, re'burn the iso to the USB drive and make double sure it's set to use EFI mode. This is easily done in Rufus. Then when that finished, reboot and enter UEFI/BIOS. Once in UEFI/BIOS look for an option that says UEFI+Legacy, click this option and set it to EFI or UEFI, then check your boot order and set the windows UEFI boot to #2 in the list and move UEFI USB key to #1, this will not mess with the booting process but will allow the computer to boot from the USB before it attempts to boot from the windows bootloader. Now save and exit. If you are unsure of the changes you are making to the boot order, take a good clear picture of the boot order before you make any changes, this way you will have a reference to look at if you need to set it back. It may boot straight into windows again but that's ok, just insert the USB drive after the boot up. Now do another restart and when the computer boots, it should boot into the USB. If it booted Linux you're on the right track. Now click the install and select the bottom option to do it manually, go through the steps and get the partitions set for /, home, and swap. Now at the drop-down it should show your WBM partition, it may or may not be selected as the default, just make sure it says something like Windows Boot Manager. This will ensure you are installing Linux in UEFI/EFI mode and placing the bootloader in the correct partition. If it doesn't show Windows Boot Manager, then you may need to use a Legacy/BIOS setup and will need to basically follow the all the same instructions only instead of using the UEFI/EFI mode; use the BIOS/Legacy mode. Rufus will help very much in setting your iso to use Legacy or EFI, but before you make the leap and force it to create the install; do some extra research to be sure it will work with your system configuration. It WILL vary depending on your motherboard manufacturer and weather it's UEFI or bios. UEFI is designed to work with both but can bring along it's own complications when installing another os alongside.

2
  • It helped me actually, I needed to boot the USB drive in EFI mode. That made the difference. Thanks man!
    – silver_mx
    May 7 '18 at 12:13
  • Welcome, glad to hear you got it going. 👍
    – LKaan
    May 8 '18 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.