1

Ubuntu 17 on VMWare - Network was working fine, suddenly not. Tried Bridging and NAT to no avail so I'm looking at the linux side.

$ ifconfig -a
ens33: flags=4098<BROADCAST,MULTICAST>  mtu 1500
    ether 00:**:**:**:**:**  txqueuelen 1000  (Ethernet)
    RX packets 0  bytes 0 (0.0 B)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 0  bytes 0 (0.0 B)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
    inet 127.0.0.1  netmask 255.0.0.0
    inet6 ::1  prefixlen 128  scopeid 0x10<host>
    loop  txqueuelen 1000  (Local Loopback)
    RX packets 1876  bytes 114200 (114.2 KB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 1876  bytes 114200 (114.2 KB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Looks to me like the interface is disabled:

$ ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: ens33: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
link/ether 00:0c:29:f8:f7:47 brd ff:ff:ff:ff:ff:ff

But ifup doesn't seem to know ens33 (or eth0):

$ ifup ens33
Unknown interface ens33
$ ifup eth0
Unknown interface eth0
  • did you check that your wmware adaptater is not unplug ? – Kiwy Mar 25 '18 at 18:33
  • What does "unplugged" mean in a VM context? I can confirm that the "Connect" box was unchecked and grayed out but this is still the case and networking works. – Marc Mar 25 '18 at 18:59
2

OK, it seems the interface did not "exist".

Add the following line to /etc/network/interfaces:

iface ens33 inet dhcp

Switch it on (enable it):

sudo ifup ens33

Good to go:

ping google.com

Yay!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.