0

I'm trying to create a simple network using the following xml:

<network>
  <name>net-bridge</name>
  <forward mode="bridge"/>
  <bridge name="virbr0"/>
</network>

Resulting in this error:

gthost ~ # virsh net-define net-bridge.xml 
error: Failed to define network from net-bridge.xml
error: this function is not supported by the connection driver: virNetworkDefineXML

Similar error messages related to network creation if I try creating a domain with "virsh define ". Same error appears if I try to install the guest using virt-install. Don't know where to even begin looking for clues.

  • What are you trying to do with <forward mode='bridge'/>? This is intended for connecting to existing bridges not managed by libvirt, such as those provided by Open vSwitch. It probably is not what you want. – Michael Hampton Mar 22 '18 at 17:13
  • It really doesn't matter what I define, this was just an example and the bridge did exist. I've tried several other network types. Even if I type virus net-list I get this error. – Adrian C Mar 22 '18 at 18:45
  • The next obvious question is, what hypervisor are you connecting to? – Michael Hampton Mar 22 '18 at 20:19
  • KVM on a gentoo fresh install. I ventured into gentoo which I am a total beginner at but I will hold off for now and stick with ubuntu. Thanks for helping out. – Adrian C Mar 25 '18 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.