1

I'm running Manjaro Linux and trying to install Discord app. Since Discord doesn't have an official build for Arch-based systems, I've tried to use yaourt and the install gives me this error:

==> Verifying source file signatures with gpg...
llvm-6.0.0.src.tar.xz ... FAILED (unknown public key 0FC3042E345AD05D)
libcxx-6.0.0.src.tar.xz ... FAILED (unknown public key 0FC3042E345AD05D)
libcxxabi-6.0.0.src.tar.xz ... FAILED (unknown public key 0FC3042E345AD05D)
==> ERROR: One or more PGP signatures could not be verified!
==> ERROR: Makepkg was unable to build libc++.
==> Restart building libc++ ? [y/N]

So even if I type "Y" to restart the build, it doesn't work because it stops at the same error again.

Is there a way to get those three public keys and manually point to them? Or another way to install the package?

1

When installing Discord, during the install the system will try to validate the PGP signatures for libc++. The signatures should be added by the user, as seen on the package instructions in the AUR (here).

During the install the system will ask if you want to edit the PKGBUILD, and you should input "yes". Search for the keys there, on the validpgpkeys array.

Copy those two keys and run in a separate window the command:

gpg --recv-keys <KEY_A> <KEY_B>

Replace KEY_A and KEY_B with the signatures found on the PKGBUILD file.

After importing those keys you should see something like this:

gpg: key 0FC3042E345AD05D: 3 signatures not checked due to missing keys
gpg: key 0FC3042E345AD05D: public key "Hans Wennborg <hans@chromium.org>" imported
gpg: key 8F0871F202119294: 3 signatures not checked due to missing keys
gpg: key 8F0871F202119294: public key "Tom Stellard <tom@stellard.net>" imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 2
gpg:               imported: 2

And then you can proceed with the libc++ installation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.