So I was on my desktop computer as usual, and then this happens out of nowhere:

enter image description here

For the little time that I've researched about the error, the first message [Firmware Bug]: the BIOS has corrupted hw-PMU seems to be related to HP hardware (I have a printer connected to my computer). The problem is that my CentOS 7 is not booting anymore. I guess that the problem might be because of the following message: Corruption of in-memory data detected. Shutting down filesystem. I'm also asking this question on the same desktop computer using Windows on a dual boot.

Is there a way to recover from this? I don't even know where to start looking for a fix.


When I try to boot into CentOS, it displays me the same lines shown in the image (the ones starting with [ 2.0XXXXX] XFS (dm-1) ... and then it enters in emergency mode. It then tells me that there's a log file at /run/initramfs/rdsosreport.txt. I wanted to copy that file to a USB drive so that I could share the error log, but apparently I can't mount it.

Using dmesg I can see that my pendrive is detected, but no name is associated to it in the dev directory. I've tried formatting my pendrive to ext2 but I still have the same problem. Is there anything I'm missing here?

Any help is appreciated.


It turned out that I had my root filesystem currupted by the crash, as stated in the comments. I followed shodanshok's suggestion and booted a live CentOS image on my USB stick, then I went to Troubleshooting and selected the option to rescue an existing installation of CentOS.

Funnily enough, the live image stated that no Linux installation were found on my hard drive, so I didn't know what to do again. I returned to Google to search for a solution and found this blog post. The guy there apparently had the same problem, and he solved it using this command: xfs_repair -L /dev/mapper/centos-root.

I returned to my live USB boot and selected the rescue option. The live system couldn't find my Linux installation as before. That time I entered the shell and ran fdisk -l to see if I could manually find and mount my system partition. fdisk showed me the existence of a 50Gb sized /dev/mapper/cl-root. I wasn't able to mount it. I then ran the command xfs_repair -L /dev/mapper/cl-root to see what would happen. When the process ended, I rebooted my computer and CentOS is now starting without errors.

  • 2
    I think, there is only root filesystem corruption. Look for XFS recovery help. Mar 20, 2018 at 4:46
  • I just did a little more research and that seems to be the case. I'll try running a CentOS rescue disk and see where this leads me. Thanks for the help!
    – Pedro
    Mar 20, 2018 at 11:47

1 Answer 1


Something caused a memory corruption, which was propagated to the root filesystem (to its journal, to be precise). So XFS shutdown itself down. To correct the issue, boot from a live CentOS disk and execute xfs_repair.

After that, you had to determine what caused the memory corruption. I see two main possibilities (other than bad luck):

  • a RAM module failing, which you can hunt down by running memtest86 for 2+ hours;
  • a bad/defective SATA/power cable or a bad PSU, which caused bad metadata on the disk drive and a subsequent shutdown on metadata reads. Please report the output of smartctl -a <disk> to check for this problem.
  • Executing xfs_repair did solve my problem. I'll update my question with how I solved it as it might help future users. Mar 21, 2018 at 1:38
  • Thanks for a tip. I have a same problem on ext4, I'll run fsck.ext4.
    – pevik
    Jun 19, 2020 at 22:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .