0

I am booting from a Puppy Linux USB Flash drive so that I can tar the primary partition of the hard drive. I see sda2 through to sda15, sdb1 to 15 (sdb1 is USB boot disk), sdc1 to 15, sdd1 to 15, sde1 to 15, etc. But I do not see sda1.

When I boot normally (not with the flash drive), I do see sda1, as well as 2 & 5

Why am I not seeing sda1 when booting from flash drive?

Also would like to know why I am seeing a multitude of other sd_'s which are not there when booting normally.

10
  • which puppy linux please. // device nodes in /dev can be created statically, for an anticipated number of partitions - this is how systems used to work before hotplug support. compare cat /proc/partitions or ls /sys/class/block for the kernel's idea of what devices are really available. i'm not sure why sda1 would be missed out from the pre-created device nodes though. you could try udevadm trigger to get udev to rescan /sys, if that has the same problem of not creating sda1 then hopefully the problem will show as an error message in the system log.
    – sourcejedi
    Mar 20 '18 at 19:09
  • Thank you. I'll try out what you've suggested. Cant remember off the top of my head what version of Puppy it was. I'll come back with that if necessary. Mar 21 '18 at 15:17
  • The hope is you can update this q/a, hopefully because you found a solution to your problem, then you should include the Puppy version because it will give people information about the scope of the error you hit. e.g. if someone saw the same error in an earlier version, this might tell them that simply upgrading to your version might not help.
    – sourcejedi
    Mar 21 '18 at 15:27
  • 1
    Sorry I took so long coming back to this. At the time I ended up building from scratch rather than cloning. But now I have come across the same issue again. Version of Puppy Linux is 5.01, 'cat /proc/partitions' shows what I would expect to see (sda1,2 & 5) and so does 'ls /sys/class/block'.. 'udevadm trigger' does not seem to make any difference although no errors, cant see anything that looks relevant in /var/log/messages.. The objective is to copy the hard disk to another unit May 1 '18 at 10:23
  • 1
    OK so the problem was that the boot stick is 32 bit and the unit is 64 bit.. I tried a 64 bit boot stick and all is ok May 1 '18 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.