3

Here's a screenshot of the seemingly relevant settings.

Alt+Tab (Forward) works; Alt+Shift+Tab (Reverse) does nothing.

Any suggestions for a fix or where exactly I should direct a bug report?

screenshot

4
  • 1
    Bugs can be filed here. I actually find people there quite unresponsive. The forum, however, is very helpful, if you get nothing useful here.
    – Sparhawk
    Commented Mar 20, 2018 at 9:16
  • thanks. would mark correct if it were an answer Commented Mar 29, 2018 at 23:36
  • Good point. I should have read your question more thoroughly. I've changed it into an answer.
    – Sparhawk
    Commented Mar 30, 2018 at 0:22
  • I confirm the bug is present in Kubuntu 16.04 and 18.04
    – trig-ger
    Commented Sep 9, 2018 at 19:18

3 Answers 3

2

It looks like the reason is that Alt+Shift+Tab translates to Alt+Shift which switches the keyboard layout and consecutive Alt+Tab which traverses the opened applications in the non-reversed order. I think this is a bug and it is really uncomfortable for anyone with more than one keyboard layout.

It looks this is an old bug which was fixed

However in Kubuntu 18.04 it appears again.

09:40:05:~$ plasmashell --version
plasmashell 5.12.6
09:40:10:~$ kf5-config --version
Qt: 5.9.5
KDE Frameworks: 5.44.0
kf5-config: 1.0
2
  • 1
    Thanks. I don't think that could be my issue though because I only have 1 keyboard layout & Alt + Shift doesn't seem to be an enabled shortcut for it. Under Input Devices> Keyboard Hardware & Layout, I found an option to use Alt + Shift that way, but it's not selected. However, under Misc. I see something about handling Ctrl & Alt special keys in a server, so I will try that one & report back if it works Commented Jul 11, 2018 at 19:52
  • I set the handle ctrl & alt keys in server option & clicked restore to defaults in window switcher settings. No immediate change. But upon restart it finally works. (sorry for ambiguity on which solved it) Commented Jul 15, 2018 at 7:16
1

Any suggestions for a fix or where exactly I should direct a bug report?

Bugs can be filed here. I actually find people there quite unresponsive. The forum, however, is very helpful, if you get no other useful answers here.

1

It's indeed considered a somewhat "bug"-ish, yet it also depends on the perspective...

Meanwhile, however, just in case, have you tried: CtrlAltTab instead of AltShiftTab?
It may be a temporary workaround if AltShift is set in Xorg for layout switching/toggling (i.e. grp:alt_shift_toggle) and considering the following:

The X server does not know about any shortcuts -- shortcuts are the domain of the desktop environment. Maybe in Windows layout-switching and shortcut-recognition happen in the same component, so it can hold off switching layouts until Shift and/or Alt is released to see if maybe another key will be pressed. But in X, layout switching happens in the server, and as soon as the switching combo is seen, the layout is switched and the combo is dropped.

Source: GitLab (freedesktop.org)


For example: Ctrl+Alt+Tab

It depends on the current shortcuts and may indeed appear non-comfortable enough (subjective...), yet the wonderful Ctrl key is near Shift on the most of the keyboards and may have been waiting all this time just for you! ^^


Related: [XKB] need to kick hotkeys on release, not press

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .