0

I'm running the following command on terminal:

$ /usr/bin/chromium-browser --proxy-server="socks5://127.0.0.1:9050" --host-resolver-rules="MAP * ~NOTFOUND, EXCLUDE 127.0.0.1, EXCLUDE 192.168.1.106" 2>&1 >/dev/null &

After chromium is opened, I cannot get to 192.168.1.106:4004 at which a NodeJS app is running. Despite the fact that I've excluded 192.168.1.106 in the --host-resolver-rules option.

Just to double-check, I can get to 192.168.1.106:4004 when opening chromium by just running:

$ /usr/bin/chromium-browser 2>&1 >/dev/null &

Therefore, I need to modify the chromium proxy options but I couldn't figure out which ones. Does anybody know how I can exclude 192.168.1.106 address?

1

According to the official documentation it's

--proxy-bypass-list=(<trailing_domain>|<ip-address>)[:<port>][;...]

So it should be

--proxy-bypass-list=192.168.1.106:4004
| improve this answer | |
  • Thanks, I tried this but didn't work: /usr/bin/chromium-browser --proxy-server="socks5://127.0.0.1:9050" --host-resolver-rules="MAP * ~NOTFOUND, EXCLUDE 127.0.0.1" --proxy-bypass-list="192.168.1.106:4004" 2>&1 > /dev/null & – user3405291 Mar 20 '18 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.