1

I installed Debian 9 Stretch to my Dell Precision M3800 and it works beautifully.... except for thermal control.

If I lshw, I get this:

*-generic:1 UNCLAIMED
     description: Signal processing controller
     product: 8 Series Chipset Family Thermal Management Controller
     vendor: Intel Corporation
     physical id: 1f.6
     bus info: pci@0000:00:1f.6
     version: 05
     width: 64 bits
     clock: 33MHz
     capabilities: pm msi cap_list
     configuration: latency=0
     resources: memory:f7a20000-f7a20fff

If i run sensors, I get:

$ sensors
dell_smm-virtual-0
Adapter: Virtual device
Processor Fan: 4800 RPM
Video Fan:     4900 RPM
CPU:            +40.0°C 



acpitz-virtual-0
Adapter: Virtual device
temp1:        +27.8°C  (crit = +105.0°C)
temp2:       -269.2°C  (crit = +105.0°C)

nouveau-pci-0200
Adapter: PCI adapter
GPU core:     +0.60 V  (min =  +0.60 V, max =  +1.20 V)
temp1:            N/A  (high = +95.0°C, hyst =  +3.0°C)
                       (crit = +105.0°C, hyst =  +5.0°C)
                       (emerg = +135.0°C, hyst =  +5.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +39.0°C  (high = +84.0°C, crit = +100.0°C)
Core 0:         +38.0°C  (high = +84.0°C, crit = +100.0°C)
Core 1:         +38.0°C  (high = +84.0°C, crit = +100.0°C)
Core 2:         +38.0°C  (high = +84.0°C, crit = +100.0°C)
Core 3:         +38.0°C  (high = +84.0°C, crit = +100.0°C)

When I run fancontrol, the fans stop completely. When I exit, fans turn on full throttle.

I have tried running fancontrol, lm-sensors and thermald but nothing seems to regulate fan speed.

I have also run pwmconfig which tries to configure fan settings, but I get:

No correlations were detected.
There is either no fan connected to the output of hwmon2/pwm1,
or the connected fan has no rpm-signal connected to one of
the tested fan sensors. (Note: not all motherboards have
the pwm outputs connected to the fan connectors,
check out the hardware database on http://www.almico.com/forumindex.php)

Did you see/hear a fan stopping during the above test (n)?

I answer with yes, because fans and I managed to generate an /etc/fancontrol with some values, but it doesn't work.

Any pointers would be greatly appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.