1

Here is my issue : when running some Docker containers, I loose the internet connection on my host and that's very annoying. The first time I noticed this issue it was with a simple mySQL container but it seems to be more general than that.

Actually, this issue appears in other situations, for instance when I initiate a swarm. I also tried with other databases containers : Postgres and couchDB.

My computer runs Debian and this is a pretty new configuration, I'm on Debian since February.

I could not find other similar issue on the internet, only people that can't access internet from their containers.

Don't hesitate to ask for more details, but I don't really know what else could I tell about this issue...

Thank you in advance for your help.

EDIT :

  1. I noticed that I have this problem only when using a wifi connection (not only at home). When using an ethernet cable, everything's fine.

  2. I had DNS issue after installing Debian when using wifi. I tested different answers but I finally solved it by setting /etc/resolv.conf immutable with my own DNS servers and I had no more problems.

  3. Here is what docker info command gives :

Containers: 6
 Running: 5
 Paused: 0
 Stopped: 1
Images: 78
Server Version: 1.13.1-cs8
Storage Driver: overlay2
 Backing Filesystem: extfs
 Supports d_type: true
 Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins: 
 Volume: local
 Network: bridge host macvlan null overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 6c463891b1ad274d505ae3bb738e530d1df2b3c7
runc version: 54296cf40ad8143b62dbcaa1d90e520a2136ddfe
init version: 949e6fa
Security Options:
 seccomp
  Profile: default
Kernel Version: 4.9.0-5-amd64
Operating System: Debian GNU/Linux 9 (stretch)
OSType: linux
Architecture: x86_64
CPUs: 4
Total Memory: 7.683 GiB
Name: Neptune
ID: HDM2:5HQT:MXPR:Y7P6:ZMMZ:JQAV:UQBP:NNM3:OZ3E:OA4S:MHGH:HJI6
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Experimental: false
Insecure Registries:
 127.0.0.0/8
Live Restore Enabled: false

WARNING: No swap limit support
  1. Here is what I get from "netstat -rn" (currently connected with an ethernet cable) netstat-rn

  2. And what I get with "ifconfig". I'm following a cloud course, many of them have been created with different tutorials : Link to my gist

  • Comments are not for extended discussion; this conversation has been moved to chat. – terdon Mar 19 '18 at 17:02
0

The default route is blocked when one of your containers creates a new route for the virtual network device

Destination Gateway     Genmask Flags MSS Window irtt Iface
0.0.0.0     0.0.0.0     0.0.0.0 U     0   0      0    veth8835bcf
0.0.0.0     192.168.0.1 0.0.0.0 UG    0   0      0    wlp2s0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.