2

I installed VirtualBoxAddition and i still cant have resolution higher than 800x600 in full-screen mode. I did it in various ways

  • Input , Insert Guest Addition CD, or by downloading iso and opening it from inside VM
  • Then i tried typing in terminal either sudo ./VBoxAddition.run or sh ./VBoxAddition.run

There goes few lines, which last is "Starting Virtual Box Addition" and no errors. After rebooting CentOS, whole VM or even host computer i still cant enable 16:9 resolution by Auto-Resize. I also checked for logs in cd /var/log There are few of them - vboxadd-install.log - vboxadd-setup.log - vboxadd-setup.log.1 - vboxadd-setup.log.2 - vboxadd-setup.log.3 - vboxadd-setup.log.4 - vboxadd-unintall.log

Inside them: (checked by nano )

  • vboxadd-install

    groupadd: group 'vboxadd' already exists

  • vboxadd-setup.log https://pastebin.com/YRXHCZUF

  • vboxadd-setup.log.1

    Removing existing VirtualBox kernel modules.

  • vboxadd-setup.log.2 pastebin.com/jzkKyRqh

  • vboxadd-setup.log.3 Removing existing VirtualBox kernel modules.

  • vboxadd-setup.log.4 https://pastebin.com/8fFvDyGT

vboxadd-uninstall.log is empty.

Could anyone please help me, i dont know what to do to get full screen 16:9 resolution on my computer in Centos & Virtual Box?

1

It seems that installation has successfully passed. Ensure that you have vboxadd-service.service and vboxadd.service started:

systemctl -t service|grep vbox

If services started, then reboot your guest machine. During the boot, when GRUB menu will be showed, press e to edit boot menu entry. Find line with linux16 (kernel parameters line) and put in the end vga=ask, then press Ctrl+x for boot. Therefore the linux kernel ask you to select appropriate graphical mode. If selected mode is convenient for you, save vga=<your_choice> to /boot/grub2/grub.conf for further boots.

2
  • Thank you a lot but i have few problems. After pressing e on boot screen and pasting vga=over, i could choose few resolutions but not one i need: 1366x768 of my laptop. Resolutions there are either too small or too big, some even makes system unable to boot. I tried editing grub.conf file with "vga=1366x768" but there was no file with this name (only grub.cfg). I wrote this line in grub.cfg and newly made grub.conf but it not helped me. Default resolution is still 4:3 800x600 with black boxes on sides of screen, – λjk.jk Mar 17 '18 at 1:25
  • @YurijGoncharuk this could be a trick, but how to get auto-resize working? – GabrieleMartini May 10 '19 at 13:45
0

To add a custom resolution for the guest (e.g. for a 1440p display):

$ vboxmanage setextradata "your vm" CustomVideoMode1 2560x1440x32
$ vboxmanage controlvm "your vm" setvideomodehint 2560 1440 32

Where your vm is the name from Machine > Settings > General > Basic > Name in VirtualBox Manager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.