I set up a pulseaudio network stream (wlan) to my raspberry pi. Therefore, after testing multiple tutorials on how to set up a audio stream via network, I succeeded with the following partly: Pulseaudio is running as a service with a the service-file /etc/systemd/system/pulseaudio.service containing

Description=PulseAudio system server
ExecStart=/usr/bin/pulseaudio --daemonize=no --system --realtime --log-target=journal --disallow-exit --disallow-module-loading --log-level=1 --exit-idle-time=-1

The host is a Ubuntu machine (4.4.0-116-generic) with paprefs installed and configured. In the configuration (raspberry pi) of pulseaudio in both /etc/pulse/system.pa and /etc/pulse/default.pa I appended

load-module module-native-protocol-tcp auth-ip-acl=;X.X.X.X/24
load-module module-zeroconf-publish

with X.X.X.X replaced by the hosts IP adress. When I start the service on the Pi via

sudo systemctl --system restart pulseaudio.service


sudo systemctl --system restart pulseaudio.service

on the host there appears the new output sink and audio is piped correctly (videos in the browser have a small desynchronisation) to the pi. But after a randomly gambled time, the connection is lost, meaning the audio stream on the pi stops and the service terminates. I sense in a way that the wlan connection could be a problem, but on the other site, if everything is running, it's running correctly. So the network connection should be good enough. Additionally pulseaudio sometimes tells itself, that it is a bad idea to run it in system wide mode, the same error occures for user-only mode . What can I do about this disconnects?

edit: When the service terminates sudo systemctl --system status pulseaudio.service tells

● pulseaudio.service - PulseAudio system server
Loaded: loaded (/etc/systemd/system/pulseaudio.service; enabled)
Active: failed (Result: exit-code) since Fr 2018-03-16 20:51:21 CET; 125ms ago
Process: 6181 ExecStart=/usr/bin/pulseaudio --daemonize=no --system --realtime --log-target=journal --disallow-exit --disallow-module-loading --log-level=1 --exit-idle-time=-1 (code=exited, status=1/FAILURE)
Main PID: 6181 (code=exited, status=1/FAILURE)

Mär 16 20:49:51 raspberrypi pulseaudio[6181]: Host part of ACL entry 'X.X.X.X/24' is not zero!
Mär 16 20:49:52 raspberrypi pulseaudio[6181]: Denied access to client with invalid authorization data.
Mär 16 20:51:21 raspberrypi systemd[1]: pulseaudio.service start operation timed out. Terminating.
Mär 16 20:51:21 raspberrypi systemd[1]: pulseaudio.service: main process exited, code=exited, status=1/FAILURE
Mär 16 20:51:21 raspberrypi systemd[1]: Failed to start PulseAudio system server.
Mär 16 20:51:21 raspberrypi systemd[1]: Unit pulseaudio.service entered failed state.

/var/log/syslog and /var/log/daemon.log tell the same:



Unfortunately, journalctl -a tells that there are no journal files.

  • Have you checked the logs? – Tomasz Mar 16 '18 at 19:14
  • I appended the logs. – guest Mar 17 '18 at 23:01
  • Does the connection break while streaming or only when idle? – Tomasz Mar 17 '18 at 23:49
  • Also check if this subnet: X.X.X.X/24 does indeed have the zero for hosts, ie. it is X.X.X.0/24. – Tomasz Mar 17 '18 at 23:54
  • The disconnects happens while streaming and while idle. ifconfig for the wlan0 connection shows the line inet address : Bcast: mask: How does this affect the pulseaudio stream? – guest Mar 18 '18 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.