1

I just switched from Ubuntu 17.10 to Debian Buster Sid, using GNOME 3.26.2.

I'm using a Thinkpad T430. See below for more information on my touchpad.

$ grep -B 5 mouse /proc/bus/input/devices
I: Bus=0011 Vendor=0002 Product=0007 Version=01b1
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input2
U: Uniq=
H: Handlers=mouse0 event1 
--
[...]

The problem is that two finger scrolling is very unprecise due to jumping. While I'm scrolling everything works fine, but as soon as I'm lifting up my fingers to stop, the page just randomly jumps or scrolls a bit randomly up or down. I never experienced such behaviour under Ubuntu.

I suspect that the motion threshold is simply to low, so that my lifting figures are detected as another scroll.

All solutions for similar issues that I found requiere to edit the conf file which, as I found out, isn't used under Wayland.

So I checked gsettings but didn't find a proper key:

$ gsettings list-keys org.gnome.desktop.peripherals.touchpad
send-events
natural-scroll
tap-to-click
two-finger-scrolling-enabled
left-handed
click-method
speed
tap-and-drag
edge-scrolling-enabled
disable-while-typing

How to fix this?

Thank you and have a nice day!

0

You might be able to debug and recalibrate the touchpad as described in Wayland Touchpad pressure-based touch detection. Basically, you run a libinput utility and press on the touchpad to see what threshold you should use:

sudo libinput measure touchpad-pressure

You then try that value out

sudo libinput measure touchpad-pressure --touch-thresholds=10:8

and finally create an overriding hwdb entry, such as /etc/udev/hwdb.d/99-touchpad-pressure.hwdb with an entry matching your keyboard, and the override:

libinput:name:*SynPS/2 Synaptics TouchPad:dmi:*
 LIBINPUT_ATTR_PRESSURE_RANGE=10:8
  • Gives me "Error: device does not have ABS_MT_PRESSURE". These are the touchpad props Device: SynPS/2 Synaptics TouchPad Kernel: /dev/input/event1 Group: 8 Seat: seat0, default Size: 76x45mm Capabilities: pointer Tap-to-click: disabled Tap-and-drag: enabled Tap drag lock: disabled Left-handed: disabled Nat.scrolling: disabled Middle emulation: n/a Calibration: n/a Scroll methods: *two-finger edge Click methods: none Disable-w-typing: enabled Accel profiles: none Rotation: n/a – DisplayName Apr 17 '18 at 10:01
  • So the pressure detection must be fixed in the device and you cannot change it. The only solution would be to write your own program that read the raw events from the device and tried to detect and suppress the spurious scroll movements. That would not be easy. You could also try using the edge scroll; perhaps it is less buggy. – meuh Apr 17 '18 at 17:53
  • @meuh: I have an identical problem with a Lenovo T520 and the same error trying your suggestion. If it is fixed in the hardware, then howcome windows 7 (previously) and windows 10 both don't have a problem with this? – Kukeltje May 13 '18 at 0:30
  • @Kukeltje I don't know how Windows does anything, but manufacturers needing to run that system are obliged for their certification to make their hardware compatible with what that software expects, or to provide drivers to interface with it, beyond any potential international norms and specifications, which is all that Linux has to work with. – meuh May 13 '18 at 7:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.