I have configured mutt to connect to my imap server. It logins and send mails successfully but I don't see any messages, it says:

Mutt: =INBOX [Msgs:0]

But I don't see any errors...

This is the configuration file:

#set attribution_locale=C
set imap_pass='abcdef(abcdefabcdefcabcdef*abcdef'
set folder="imaps://myimap.example.com/"
set imap_user="pepe.perez@example.com"
set spoolfile="imaps://$imap_user:$imap_pass@myimap.example.com"
set folder ="imaps://myimap.example.com/" 
mailboxes = +INBOX
set header_cache=~/.cache/mutt
set message_cachedir="~/.cache/mutt"
set postponed="=Borradores"
unset imap_passive
set imap_keepalive=300
set mail_check=120
set my_pass=$imap_pass
set realname='Pepe Perez'
set from="pepe.perez@example.com"
set use_from=yes
set smtp_url=smtp://$imap_user:$imap_pass@myimap.example.com:587
set editor=vim
set beep_new=yes
bind index <f5> imap-fetch-mail
set sort = reverse-date-received
set net_inc=5
set record = "=Elementos enviados"
set trash = "=Elementos eliminados"
set tmpdir = ~/tmp
set ssl_starttls=yes
set smtp_authenticators = 'login'
set net_inc=5
unset imap_passive

Using mutt Mutt 1.9.2 on Fedora 27

  • Are you certain that you actually have mail on the server? Also, are mail delivered to the INBOX mailbox or elsewhere? – Kusalananda Mar 16 '18 at 11:28
  • Yes I am. In fact I use Thunderbird, but I'd like to use mutt on cli in some cases. – sebelk Mar 16 '18 at 17:00
  • 1
    If your thunderbird settings are downloading your mail to your thunderbird folder system, there won't be any mail left on the server for mutt to read ... – user1404316 Mar 16 '18 at 17:28
  • I use only IMAP! – sebelk Mar 16 '18 at 18:40
  • Even if you only use IMAP, Thunderbird may be downloading the messages (using IMAP) and deleting them from the inbox on the server. Close Thunderbird and send yourself an email using Gmail or something. – Kusalananda Apr 15 '18 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.