0

I installed fedora with the intention of setting up a multiboot system, but when I insert a live usb stick, it doesn't boot, it just goes to fedora. I've tried two ubuntu usbs, one I had purchased and another that I made. I also tried to boot puppy. he system recognizes that the usb is there, it just doesn't boot to it. Someone reported that he'd used slackware and that worked, but fedora's mediawriter doesn't recognize slackware's installation media.

  • If you need the system to work reliably, then a multi boot setup is definitely not recommended. Too much can go wrong and it's a nightmare to troubleshoot/maintain. Use VMs instead. But, if this is an experimental learning project, Have Fun! – Mioriin Mar 20 '18 at 15:50
2

The problem isn't Fedora, the problem is the BIOS settings. Your BIOS is configured to boot to the hard drive before any USB media, so when it sees that there's a bootable Fedora image on the hard drive, it boots that and ignores any USB media you have inserted.

1

Enter your BIOS/UEFI configuration and go to the BOOT tab (usually with the arrow keys). Use up/down to select your USB drive (make sure it was inserted while booting BIOS) and press F5/F6/PGUP to move it to the top of the list. Then save BIOS config (F10 normally) to continue boot to the USB.

Alternatively, you could try following the instructions here to chainload the USB from GRUB

0

What John said is true. What you ought to do is set USBs as your highest boot priority in your BIOS. That way, it will always boot from any live USB and not any currently installed OS, unless you tell it differently. Just be sure to remove your install media when you're done. Also, if you haven't already make sure GRUB (GRand Unified Boot-loader) installs as well. GRUB allows you to easily pick an OS from which to boot everytime you start your machine. Good luck!

  • 2
    Surely this answer should be a comment? – Penn Mar 14 '18 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.