1

I bought a new laptop and installed CentOS 7.2 parallel with the original Win10 inside (dual system). When using Win10, I can see HDMI outputs to an extra monitor without problem, but it just shows no signal when I am in the CentOS.

I tried to find the solution on the Internet, but there is no luck. Many questions are about why HDMI doesn't output audio, but mine is it outputs nothing at all.

I then tried to gather some information which might be needed, and I attached the commands and the result as follows.

xrandr --verbose

Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080 
default connected primary 1920x1080+0+0 (0x17f) normal (normal) 0mm x 0mm
Identifier: 0x17e
Timestamp:  70549
Subpixel:   unknown
Clones:    
CRTC:       0
CRTCs:      0
Transform:  1.000000 0.000000 0.000000
            0.000000 1.000000 0.000000
            0.000000 0.000000 1.000000
           filter: 
_MUTTER_PRESENTATION_OUTPUT: 0 
1920x1080 (0x17f) 159.667MHz *current
    h: width  1920 start    0 end    0 total 1920 skew    0 clock  83.16KHz
    v: height 1080 start    0 end    0 total 1080           clock  77.00Hz

lspci -v | grep VGA -A20

00:02.0 VGA compatible controller: Intel Corporation Device 5916 (rev 02) (prog-if 00 [VGA controller])
Subsystem: Pegatron Device 22c4
Flags: bus master, fast devsel, latency 0, IRQ 255
Memory at b0000000 (64-bit, non-prefetchable) [size=16M]
Memory at a0000000 (64-bit, prefetchable) [size=256M]
I/O ports at 4000 [size=64]
Expansion ROM at <unassigned> [disabled]
Capabilities: [40] Vendor Specific Information: Len=0c <?>
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [ac] MSI: Enable- Count=1/1 Maskable- 64bit-
Capabilities: [d0] Power Management version 2
Capabilities: [100] #1b
Capabilities: [200] Address Translation Service (ATS)
Capabilities: [300] #13

00:08.0 System peripheral: Intel Corporation Sky Lake Gaussian Mixture Model
Subsystem: Pegatron Device 22c8
Flags: bus master, fast devsel, latency 0, IRQ 255
Memory at b122a000 (64-bit, non-prefetchable) [size=4K]
Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
Capabilities: [dc] Power Management version 2

I am wondering whether the system can detect the HDMI cable plug-in/plug-out event or not, so I use dmesg -wH to wait for the event. I found when I plug in the Ethernet cable or USB device, it shows up some information, but there is totally no response when I plug in the HDMI cable. (but it shouldn't be a hardware problem because my Win10 can recognize it)

Then I guess it is a driver problem. I tried the command below.

lsmod | grep hdmi

snd_hda_codec_hdmi     47849  1
snd_hda_codec         137386  4 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel
snd_hda_core           57760  5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_pcm               105835  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
snd                    83425  18 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device

rpm -qa | egrep "hdmi|intel"

xorg-x11-drv-intel-2.99.917-26.20160929.el7.x86_64

According to the information above, I think I have the needed driver (I guess) installed. However, the system cannot recognize it (dmesg no response). Can anybody help me on this issue? Any hint only is also appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.